Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232831 - Needs hard-coded metacity dependency
Summary: Needs hard-coded metacity dependency
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-18 15:05 UTC by Bastien Nocera
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 21:54:52 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-03-18 15:05:30 UTC
compiz-0.3.6-2.fc7

1. Install FC6 (or at least the FC6 metacity)
2. Do a "yum -y update --enablerepo=development compiz"
3. The new compiz is installed
4. Try to switch to using compiz:
gtk-window-decorator will crash

The problem is that compiz uses a library private to metacity, and its interface
must have changed between FC6 and F7, thus making gtk-window-decorator crash in
metacity code.

compiz should hard-code its dependency on metacity (and its private library) to
avoid such problems.

Installing metacity from F7 as well makes it work fine.

Comment 1 Kristian Høgsberg 2007-03-28 21:54:52 UTC
Ah, ok, I added

  Requires:       metacity >= 2.18

to the spec file.


Note You need to log in before you can comment on or make changes to this bug.