Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232829 - kernel crach under heavy disk load
Summary: kernel crach under heavy disk load
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2007-03-18 14:55 UTC by Edmond Hui
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-08 03:01:42 UTC


Attachments (Terms of Use)
kernel crash screen shot (deleted)
2007-03-18 14:55 UTC, Edmond Hui
no flags Details
part 1 of 2 crash screen (deleted)
2007-03-20 01:17 UTC, Edmond Hui
no flags Details
part 2 of 2 crash screen (deleted)
2007-03-20 01:19 UTC, Edmond Hui
no flags Details

Description Edmond Hui 2007-03-18 14:55:48 UTC
Description of problem:
Kernel panic when running mencoder. I encountered a few similar cases, mostly
related to heavy disk access with DVD burning, MySQL. The server is also running
web server, mail server, bittorrent.

Version-Release number of selected component (if applicable):
kernel 2.6.20-1.2925.fc6

hw setup:
MSI RS480M2-IL m/b (see
http://www.msicomputer.com/product/p_spec.asp?model=RS480M2-IL&class=mb), AMD X2
3800+, 2 SATA HDD running hardward RAID from m/b, 2 ATA-100

This problem been happening since 2.6.19, 2.6.18 also have some disk related
problem (DVD burning failed/crash), but disk access is stabled

How reproducible:
quite often 6/10 times

Steps to Reproduce:
run mencoder to convert mpeg video (capture by WinTV250 TV capture card) to avi.
mencoder filename -ovc frameno -o frameno.avi -oac mp3lame -lameopts vbr=3
mencoder filename -ovc lavc -lavcopts vcodec=mpeg4:vpass=1 -oac copy -o filename.avi
mencoder filename -ovc lavc -lavcopts vcodec=mpeg4:vpass=2 -oac copy -o filename.avi

When burning DVD, I am using k3b, the hangs happened when verifying DVD burned.
  
Actual results:
kenerl panic, see attach screenshot

Expected results:
no error should encounter

Additional info:
I run smolt to collect my system setup, hw-uuid 72b5ecb7-7d79-4221-a16f-9e87491d3787

Comment 1 Edmond Hui 2007-03-18 14:55:48 UTC
Created attachment 150333 [details]
kernel crash screen shot

Comment 2 Chuck Ebbert 2007-03-18 22:30:38 UTC
Please try to boot in 50-line mode and capture the entire oops.


Comment 3 Edmond Hui 2007-03-18 22:39:44 UTC
how to do that?

Rgds,

Comment 4 Dave Jones 2007-03-18 23:14:45 UTC
add vga=1 to your boot command line.


Comment 5 Edmond Hui 2007-03-18 23:41:46 UTC
I added it to /etc/grub.conf but it didn't work for me... I think my LCD display
didn't support 50-line text mode

Comment 6 Chuck Ebbert 2007-03-19 15:26:19 UTC
Everything supports 50-line boot mode. Sometimes the default font
causes problems, though. You can just rename the directory
/lib/kbd/consolefonts to /lib/kbd/consolefonts.save ... just be
sure to put it back after you are done. There will be annoying messages
about "not able to find default font" but they are harmless.

Or you could try "vga=792" for really small fonts...


Comment 7 Edmond Hui 2007-03-19 15:29:27 UTC
It's very unstable, I rollback default kernel back to 2.6.18 now. But I wil try
to reproduce it tonight.

Thanks for the response.

Rgds,

Comment 8 Edmond Hui 2007-03-20 01:17:24 UTC
Created attachment 150452 [details]
part 1 of 2 crash screen

Comment 9 Edmond Hui 2007-03-20 01:19:17 UTC
Created attachment 150453 [details]
part 2 of 2 crash screen

Comment 10 Edmond Hui 2007-03-20 13:52:46 UTC
BTW, should point out that even under 2.6.18. Sometime the kernel reboot (after
panic??) under heavy disk load... but 2.6.19/20 makes it worst that he panic
frezzed.....

Comment 11 Edmond Hui 2007-03-28 13:40:37 UTC
any news on this?

cheers,

Comment 12 Jon Stanley 2008-01-08 01:53:00 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 13 Edmond Hui 2008-01-08 02:59:18 UTC
Hi,

I have not reproduce it in FC8, so please close this.


Note You need to log in before you can comment on or make changes to this bug.