Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232796 - fedora's firefox incorrectly renders svg
Summary: fedora's firefox incorrectly renders svg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 22:45 UTC by Adam Pribyl
Modified: 2018-04-11 08:10 UTC (History)
5 users (show)

Fixed In Version: 2.0.0.5-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-30 09:54:05 UTC


Attachments (Terms of Use)
rendering in Epiphany 2.16.3-3.fc6 (deleted)
2007-03-17 22:50 UTC, Matěj Cepl
no flags Details

Description Adam Pribyl 2007-03-17 22:45:07 UTC
Description of problem:
When displaying svg in firefox from default fedora installation the svg image is
garbled. Check e.g.:
http://www.lowlevel.cz/log/images/tuxtosh3.svg

Version-Release number of selected component (if applicable):
firefox-1.5.0.10-5.fc6

How reproducible:
always
  

Expected results:
Check the firefox downloaded from mozilla.com pages.

Additional info:
Could be related to cairo?!

Comment 1 Matěj Cepl 2007-03-17 22:50:46 UTC
Created attachment 150321 [details]
rendering in Epiphany 2.16.3-3.fc6

Just to add one data-point -- this is rendering in epiphany on FC6. Looks
garbled to me as well.

Comment 2 Adam Pribyl 2007-03-18 21:51:09 UTC
Definitely. But epiphany is also using gecko - I'll bet on some library behind.

Comment 5 Martin Stransky 2007-03-26 11:35:46 UTC
Hm, all our gecko apps look broken.

Comment 6 Martin Stransky 2007-03-26 13:22:22 UTC
Looks like a problem with system cairo library. When firefox is built with
"--disable-system-cairo", svg rendering works fine. Reassigning.

Comment 7 Martin Stransky 2007-03-26 13:23:08 UTC
btw. broken in rawhide, too.

Comment 8 Adam Pribyl 2007-05-23 10:59:42 UTC
Still present in latest rawhide liveCD image for F7.

Comment 9 Sylvain Pasche 2007-05-24 22:47:52 UTC
Launchpad bug (also affecting Ubuntu):

https://bugs.launchpad.net/fedora/+source/firefox/+bug/99368

Comment 10 Sylvain Pasche 2007-07-30 09:51:39 UTC
This is fixed in version 2.0.0.5-1.fc7

Comment 11 Martin Stransky 2007-07-30 09:54:05 UTC
aha, thanks for the notice.


Note You need to log in before you can comment on or make changes to this bug.