Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232784 - httpd segfaults during some operations.
Summary: httpd segfaults during some operations.
Keywords:
Status: CLOSED DUPLICATE of bug 231848
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 6
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 19:09 UTC by Victor Bogado
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 10:20:56 UTC


Attachments (Terms of Use)

Description Victor Bogado 2007-03-17 19:09:39 UTC
Description of problem:

I have noticed that httpd is segfaulting with some operations. 

I have seen this in two specific cases one is with trac, when it is used through
the modpython option, the problem does not appear when trac is configured as a cgi. 

Another problem is happening in a php application that I am developing, php is
also configured to work as a module. 

I attempted to create a coredump using the configuration directive
CoreDumpDirectory" to instruct httpd to dump in the /tmp dir but no dump was
placed there. 

What I am seeing is that the httpd closes the connection immediately after the
browser sent the data to the server, after that the error log show the following
line : 

[Sat Mar 17 16:05:36 2007] [notice] child pid 13954 exit signal Segmentation
fault (11)

The main message log of the system also reports this : 

Mar 17 16:05:35 gandalf kernel: httpd[13954]: segfault at 00007fff4cad3ff8 rip
00002aaaac7e5c6f rsp 00007fff4cad3fe0 error 6

In the trac case the problem happens all the time with any configured trac
project, but in the php case it only happen with a single script, other scripts
of the same project do not trigger this behavior.

Comment 1 Victor Bogado 2007-03-17 19:23:28 UTC
Apparently my php code was getting into an infinite loop, that maybe the reason
of the segfault. 

I still have no clue about the trac problem, if there is anyway that I could
help in the diagnose of the source of the problem please ask. 

Comment 2 Luming Yu 2007-03-19 03:06:38 UTC
Do you see similar segfaults on ia32 box?
Do you see same segfaults on the latest verison of httpd and kernel?
Does FC7 has same problem.



Comment 3 Joe Orton 2007-03-19 10:20:56 UTC

*** This bug has been marked as a duplicate of 231848 ***


Note You need to log in before you can comment on or make changes to this bug.