Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232782 - "Open Files" selection remembered wrongly
Summary: "Open Files" selection remembered wrongly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 17:09 UTC by Tim Waugh
Modified: 2008-02-05 11:21 UTC (History)
1 user (show)

Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-05 11:21:33 UTC


Attachments (Terms of Use)

Description Tim Waugh 2007-03-17 17:09:01 UTC
Description of problem:
File->Open dialog pre-selects the previously opened file(s).  However, it gets
it wrong.

Version-Release number of selected component (if applicable):
gimp-2.2.13-1.fc6

How reproducible:
100%

Steps to Reproduce:
1.File->Open
2.Navigate to /usr/share/pixmaps
3.Select these four files:

gnome-html.png
gnome-image-gif.png
gnome-image-jpg.png
(NOT gnome-irc.png)
gnome-laptop.png

4.Click OK.
5.Close the four image windows
6.File->Open again.  Now observe which files are selected.

Actual results:
gnome-set-time.png
gnome-squeak.png
gnome-suse.png
gnome-talk.png

Expected results:
gnome-html.png
gnome-image-gif.png
gnome-image-jpg.png
gnome-laptop.png

Additional info:
It's as if the selection is being mirrored vertically!

Seen on both x86_64 and i386.

Comment 1 Zoltán Magyar 2007-05-03 17:49:46 UTC
Couldn't reproduce on i386 with the given steps. I tried also with other files.
I tested on two different systems. 

Comment 2 Tim Waugh 2007-05-04 12:02:07 UTC
I can reproduce this still, even on a clean install of F7t4 updated with yum.

x86_64:
gimp-2.2.13-1.fc6
gtk2-2.10.8-3.fc6

i386:
gimp-2.2.14-1.fc7
gtk2-2.10.11-5.fc7


Comment 3 Nils Philippsen 2007-05-04 12:09:10 UTC
I couldn't reproduce it either (only tried it with 2.2.14, though). I'll be on
vacation for the next 2 1/2 weeks, so be patient with me on that one ;-).

Comment 4 Nils Philippsen 2008-01-28 10:55:38 UTC
Tim, can you reproduce this with gimp 2.4.x on Fedora 7 or 8?

Comment 5 Tim Waugh 2008-02-05 10:42:52 UTC
No, it's working in Fedora 8.

Comment 6 Nils Philippsen 2008-02-05 11:21:33 UTC
I guess I'll close this one then.


Note You need to log in before you can comment on or make changes to this bug.