Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232771 - texdoc searches $TEXMF/doc -- should use $TEXMFDOCS
Summary: texdoc searches $TEXMF/doc -- should use $TEXMFDOCS
Keywords:
Status: CLOSED DUPLICATE of bug 232769
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 12:49 UTC by George N. White III
Modified: 2013-07-02 23:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-17 14:42:15 UTC


Attachments (Terms of Use)

Description George N. White III 2007-03-17 12:49:01 UTC
Description of problem: documentation is not found if system uses a non-default
TEXDOCS path


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. add non-standard directory to TEXDOCS in texmf.cnf
2. texdoc fails to find the new documentation
3.
  
Actual results:


Expected results:


Additional info:

Here is the patch posted to the tex-live list by Frank Küster:

Subject: [tex-live] texdoc should always use TEXDOCS

Hi,

a Debian user has noticed that, although texdoc uses 'kpsewhich
--format="TeX system documentation"' and thus the $TEXDOCS variable for
its main work, the search mode accesses $TEXMF/doc directly and ignores
changes/additions in TEXDOC.

The following patch would make it more consistent:

--- src/Upstream-source/TeXLive/Build/source/texk/tetex/texdoc.orig	2007-03-
15 16:36:30.000000000 +0100
+++ src/Upstream-source/TeXLive/Build/source/texk/tetex/texdoc	2007-03-15 
16:37:20.000000000 +0100
@@ -140,7 +140,7 @@
 do
   case $mode in
     search)
-      find `kpsewhich --expand-path='$TEXMF/doc' | tr : ' '` -type f -print |
+      find `kpsewhich --expand-path='$TEXDOCS' | tr : ' '` -type f -print |
         egrep $name
       continue
       ;;

(too simple to be copyrightable, of course).

Comment 1 George N. White III 2007-03-17 14:42:15 UTC
Bugzilla gives error "invalid product name, press back", but the bug was 
entered anyway

*** This bug has been marked as a duplicate of 232769 ***


Note You need to log in before you can comment on or make changes to this bug.