Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232762 - Confusing '--help' output
Summary: Confusing '--help' output
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-file-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 11:14 UTC by Enrico Scholz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-03 14:58:13 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2007-03-17 11:14:26 UTC
[I could not find an upstream bugreport address in the package; therefore,
 I report it here]

Description of problem:

The '--help' output is confusing because it does not give an indication
whether arguments are required resp. how they are to use:

| $ desktop-file-install --help   
|  -m, --mode                      Set the given permissions on the destination file.

--> where have I to give the mentioned permissions?


Help screen from previous versions (0.10) was much clearer:

| $ desktop-file-install --help
|   -m, --mode=STRING                Set the given permissions on the


Ditto for other options like '--add-category' or '--dir'



Version-Release number of selected component (if applicable):

desktop-file-utils-0.12-7


How reproducible:

100%

Comment 1 Ray Strode [halfline] 2007-03-19 13:57:35 UTC
Hi,

The upstream bugzilla is at bugs.freedesktop.org

Comment 2 Ray Strode [halfline] 2007-04-03 14:58:13 UTC
Can you report the bug there? Thanks.


Note You need to log in before you can comment on or make changes to this bug.