Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232756 - selinux policy problem with ntpdate/ntpd and firstboot
Summary: selinux policy problem with ntpdate/ntpd and firstboot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 08:28 UTC by G.Wolfe Woodbury
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-24 09:05:36 UTC


Attachments (Terms of Use)
setroubleshooter alert (deleted)
2007-03-17 08:28 UTC, G.Wolfe Woodbury
no flags Details

Description G.Wolfe Woodbury 2007-03-17 08:28:21 UTC
Description of problem:
  Setroubleshooter reports a problem with ntpdate doing a pipefs write in the
context of firstboot.  It requests that a bug report be filed.


Version-Release number of selected component (if applicable):
ntp-4.2.4p0-1.fc7
selinux-policy-targeted-2.5.8-5.fc7

How reproducible:
unknown


Steps to Reproduce:
1. rawhide install of 2007-03-16
2. configure ntp "sync before starting"
3.
  
Actual results:
AVC message:
avc: denied { write } for comm="ntpdate" dev=pipefs egid=0 euid=0
exe="/usr/sbin/ntpdate" exit=0 fsgid=0 fsuid=0 gid=0 items=0 name="[8959]"
path="pipe:[8959]" pid=2277 scontext=system_u:system_r:ntpd_t:s0 sgid=0
subj=system_u:system_r:ntpd_t:s0 suid=0 tclass=fifo_file
tcontext=system_u:system_r:firstboot_t:s0 tty=(none) uid=0

Expected results:


Additional info:
setroubleshooter alert attached

Comment 1 G.Wolfe Woodbury 2007-03-17 08:28:21 UTC
Created attachment 150299 [details]
setroubleshooter alert

Comment 2 Daniel Walsh 2007-03-20 14:48:13 UTC
Fixed in selinux-policy-2.5.9-1

Comment 3 G.Wolfe Woodbury 2007-03-22 11:26:01 UTC
seems to be gone, but will test more when I can get a rawhide install done later
today.

Comment 4 G.Wolfe Woodbury 2007-04-24 09:05:36 UTC
definitely gone.


Note You need to log in before you can comment on or make changes to this bug.