Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232742 - masquared connections doesn't work after kernel upgrade (again)
Summary: masquared connections doesn't work after kernel upgrade (again)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 234123 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 00:27 UTC by Vilius Šumskas
Modified: 2011-12-13 22:28 UTC (History)
2 users (show)

Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 23:25:11 UTC


Attachments (Terms of Use)

Description Vilius Šumskas 2007-03-17 00:27:36 UTC
Description of problem:
After kernel upgrade from version 2.6.19-1.2911.6.5.fc6 to 2.6.20-1.2925.fc6 
oidentd doesn't return idents to masquared connections anymore. This is because 
in the kernel 2.6.20.x there are /proc/net/ip_conntrack no more (huh? w.f?!). 
It is now called /proc/net/nf_conntrack.

Version-Release number of selected component (if applicable):
oidentd-2.0.8-2.fc6

Comment 1 Vilius Šumskas 2007-03-18 08:04:43 UTC
Moreover, the file syntax changed a little bit.

Comment 2 Chuck Ebbert 2007-03-27 14:22:01 UTC
We need to enable backwards-compatible /proc and sysctl entries:

NF_CONNTRACK_PROC_COMPAT=y

Comment 3 Chuck Ebbert 2007-03-27 14:23:14 UTC
*** Bug 234123 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.