Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232680 - Hibernation or Suspend do not have the necessary permissions
Summary: Hibernation or Suspend do not have the necessary permissions
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 16:29 UTC by Aurelien Bompard
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 14:48:02 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2007-03-16 16:29:19 UTC
Description of problem:
Clicking on suspend of hibernate in gnome-power-manager brings up the
screensaver. After entering the password, there is a popup saying that HAL did
not manage to suspend/hibernate
In /var/log/messages, I get :

gnome-power-manager: (abompard) Mise en veille de l'ordinateur car l'utilisateur
a cliqué sur mise en veille à partir du menu de la zone de notification
NetworkManager: <info>  Going to sleep. 
gnome-power-manager: (abompard) Permission denied: Not in active session
code='30' quark='g-exec-error-quark'
gnome-power-manager: (abompard) Reprise de l'ordinateur
gnome-power-manager: (abompard) suspend failed

I suspect ConsoleKit since it says "not in active session".

# LANG=C service ConsoleKit status
console-kit-daemon (pid 2154) is running...
# sestatus 
SELinux status:                 disabled

Version-Release number of selected component (if applicable):
ConsoleKit-0.1.3-0.git20070301.1.fc7

How reproducible:
Always

Comment 1 Will Woods 2007-03-30 18:45:08 UTC
If you haven't turned off SELinux, please update selinux-policy-targeted and try
again. This works for me with the current selinux-policy-targeted (2.5.10-2). 

Comment 2 Aurelien Bompard 2007-04-02 14:48:02 UTC
OK, works now (well, my graphic driver doesn't resume, but that's another story).
Thanks.


Note You need to log in before you can comment on or make changes to this bug.