Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232674 - Error org.freedesktop.Hal.PermissionDenied when mounting any usb media
Summary: Error org.freedesktop.Hal.PermissionDenied when mounting any usb media
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
: 232774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 15:54 UTC by Robert Kromer
Modified: 2013-03-06 03:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-02 21:48:20 UTC


Attachments (Terms of Use)

Description Robert Kromer 2007-03-16 15:54:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2

Description of problem:
When attempting to mount any USB media hal yells:
Error org.freedesktop.Hal.PermissionDenied
"Not in active session"

which is similar to bug #230958

HOWEVER,
I AM logged in through GDM

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Boot Fedora
2. Login Through GDM
3. Plug in flash drive or external hard drive

Actual Results:


Expected Results:


Additional info:
My system is up to date as of 03/16/07 11:00am EST

There is nothing reported in /var/log/messages or secure about it
Same problem with SElinux enabled or Permissive
From searching other bugs I'm guessing its a console-kit problem
here is some console kit output:

echo $XDG_SESSION_COOKIE
1174056563.589030-815112834

cat /var/lib/hal/acl-list
/dev/adsp       u       500
/dev/adsp       u       42
/dev/audio      u       500
/dev/audio      u       42
/dev/audio1     u       500
/dev/audio1     u       42
/dev/dsp        u       500
/dev/dsp        u       42
/dev/dsp1       u       500
/dev/dsp1       u       42
/dev/mixer      u       500
/dev/mixer      u       42
/dev/mixer1     u       500
/dev/mixer1     u       42
/dev/scd0       u       500
/dev/sequencer  u       500
/dev/sequencer  u       42
/dev/sequencer2 u       500
/dev/sequencer2 u       42
/dev/snd/controlC0      u       500
/dev/snd/controlC0      u       42
/dev/snd/controlC1      u       500
/dev/snd/controlC1      u       42
/dev/snd/pcmC0D0c       u       500
/dev/snd/pcmC0D0c       u       42
/dev/snd/pcmC0D0p       u       500
/dev/snd/pcmC0D0p       u       42
/dev/snd/pcmC0D1c       u       500
/dev/snd/pcmC0D1c       u       42
/dev/snd/pcmC0D2c       u       500
/dev/snd/pcmC0D2c       u       42
/dev/snd/pcmC0D3c       u       500
/dev/snd/pcmC0D3c       u       42
/dev/snd/pcmC0D4p       u       500
/dev/snd/pcmC0D4p       u       42
/dev/snd/pcmC1D0c       u       500
/dev/snd/pcmC1D0c       u       42
/dev/snd/pcmC1D0p       u       500
/dev/snd/pcmC1D0p       u       42
/dev/snd/seq    u       500
/dev/snd/seq    u       42
/dev/snd/timer  u       500
/dev/snd/timer  u       42
/dev/vbi0       u       500
/dev/video0     u       500

Console Kit Version: ConsoleKit-0.1.3-0.git20070301.1.fc7
Hal Version: hal-0.5.9-0.git20070304.fc7
GDM Version: gdm-2.18.0-2.fc7

Comment 1 Scott Dodson 2007-03-17 18:06:23 UTC
I get the same.  A block device (/dev/sdb1) is created and can be mounted manually.

Comment 2 David Zeuthen 2007-03-19 15:57:14 UTC
Probably CK needs an update to cope with the new changes in GDM - let me verify...

Comment 3 David Zeuthen 2007-03-19 16:08:11 UTC
*** Bug 232774 has been marked as a duplicate of this bug. ***

Comment 4 Axel 2007-03-19 22:35:40 UTC
Isn't that bug related to the problem mentionned at 
http://lists.freedesktop.org/archives/hal/2007-March/007451.html ?

Comment 5 Scott Dodson 2007-03-21 02:29:19 UTC
Problem has gone away with today's update of ConsoleKit.

Comment 6 David Zeuthen 2007-04-02 21:48:20 UTC
Looks like this bug can be closed then... feel free to reopen if the bug is
still there. Thanks.

Comment 7 cyberklin 2007-06-18 15:14:16 UTC
i have the same bug when attempting to mount any cd/dvd in nautilus.
i use gdm and xfce.

19:12:45 machine etc # echo $XDG_SESSION_COOKIE

19:12:53 machine etc # cat /var/lib/hal/acl-list
/dev/adsp       u       42
/dev/audio      u       42
/dev/dsp        u       42
/dev/mixer      u       42
/dev/sequencer  u       42
/dev/sequencer2 u       42
/dev/snd/controlC0      u       42
/dev/snd/pcmC0D0c       u       42
/dev/snd/pcmC0D0p       u       42
/dev/snd/pcmC0D1c       u       42
/dev/snd/pcmC0D2c       u       42
/dev/snd/pcmC0D3c       u       42
/dev/snd/pcmC0D4p       u       42
/dev/snd/seq    u       42
/dev/snd/timer  u       42


Comment 8 cyberklin 2007-06-18 15:22:46 UTC
and some additional information:

19:20:21 machine etc # rpm -qa | egrep "(ConsoleKit|hal|gdm)-[0-9]"
ConsoleKit-0.2.1-2.fc7
gdm-2.18.2-1.fc7
hal-0.5.9-8.fc7



Note You need to log in before you can comment on or make changes to this bug.