Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232672 - gdm facebrowser too big for 800x600
Summary: gdm facebrowser too big for 800x600
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 15:52 UTC by Adam Jackson
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 17:16:55 UTC


Attachments (Terms of Use)
HYOOOOGE (deleted)
2007-03-16 15:52 UTC, Adam Jackson
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 420610 None None None Never

Description Adam Jackson 2007-03-16 15:52:02 UTC
Description of problem:

See attached.

Version-Release number of selected component (if applicable):

gdm-2.18.0-2.fc7

How reproducible:

Oh hells yes.

Comment 1 Adam Jackson 2007-03-16 15:52:03 UTC
Created attachment 150242 [details]
HYOOOOGE

Comment 2 Ray Strode [halfline] 2007-03-20 06:06:25 UTC
So there are a couple of ways we can approach this:

1) make the face browser shorter
2) hide the face browser
3) show the plain greeter in 800x600 or lower
4) add a one off hack to show the plain greeter in 800x600 or lower if the theme
is currently "FlyingHigh"

1) actually works pretty well.  If you take ~50 pixels off or so then it fits
pretty exactly in 800x600.  The problem is the reflect is attached to the center
window, so if you make the list shorter then the reflection floats higher than
it should.  We could probably fix that with some theme tweaks.

if we go with 2) and hide the face browser then we need to hide the reflection
too because of the problem mentioned above.  That means we need to extend the
theme format, probably a new <show/> conditional ala <show min_height=1027
min_width=768/> 

if we go with 3) then I'm going to get bug reports people being upset that gdm
no longer supports their carefully crafted low resolution themes.

So 2 seems like the right way to go, but I didn't get it done today.  It's more
of a bug fix than a feature, so I can probably do it post-feature freeze, but if
that doesn't pan out, then we'll just have to go with 4, I guess.

Comment 3 David Zeuthen 2007-03-20 15:42:02 UTC
I think the best option is 2. too - agree it can be done post-feature-freeze.

Comment 4 Adam Jackson 2007-03-20 16:12:25 UTC
2 sounds right to me too.

Comment 5 Ray Strode [halfline] 2007-03-20 17:14:14 UTC
Okay, I've built the fix into 

gdm-2.18.0-5.fc7

I haven't incorporated the changes into the new theme yet, however.

Comment 6 Ray Strode [halfline] 2007-03-20 17:16:55 UTC
theme fix built into

redhat-artwork-5.0.11-2.fc7

Comment 7 David Zeuthen 2007-03-20 17:25:58 UTC
Can you share a screenshot @ 800x600 please? Thanks.

Comment 8 Ray Strode [halfline] 2007-03-20 18:21:16 UTC
for those reading this report later, I just brought David to my cube instead of
taking a screenshot.


Note You need to log in before you can comment on or make changes to this bug.