Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232661 - subscribing custom channels to a host gives Internal Server Error on Prod
Summary: subscribing custom channels to a host gives Internal Server Error on Prod
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: rhn500
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike McCune
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks: 239699
TreeView+ depends on / blocked
 
Reported: 2007-03-16 15:12 UTC by Pradeep Kilambi
Modified: 2007-05-17 02:20 UTC (History)
1 user (show)

Fixed In Version: rhn501h
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-17 02:20:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
traceback from prod (deleted)
2007-03-21 01:08 UTC, Mike McCune
no flags Details

Description Pradeep Kilambi 2007-03-16 15:12:55 UTC
Description of problem:
When I try to change subscription to a host to include custom channels through
the ui, I get a ISE. 

How reproducible:
always

Steps to Reproduce:
1. Create a custom channel
2. goto your host -> Alter channel subscriptions 
3. select the custom channel to subscribe to your host and clieck "change
subscriptions"
4. should see an ISE.
  
Actual results:
ISE

Expected results:
Altering subscriptions should be successful

Additional info:

this only happens for custom channels, other child channel subscription
alterations work fine.

Comment 1 Pradeep Kilambi 2007-03-16 15:14:27 UTC
oh and forgot to mention in the description that this is on prod webui:

link:
https://rhn.redhat.com/rhn/systems/details/SystemChannels.do?sid=1007327491

Comment 2 Bret McMillan 2007-03-16 20:13:06 UTC
Ouch, need to fix this one...

Comment 3 Mike McCune 2007-03-21 01:08:24 UTC
Created attachment 150545 [details]
traceback from prod 

Caused by: com.redhat.rhn.manager.system.IncompatibleArchException: The server
architecture (x86_64) is incompatible with the channel architecture (IA-32)
	at
com.redhat.rhn.manager.system.SystemManager.subscribeServerToChannel(SystemManager.java:939)

	at
com.redhat.rhn.manager.system.UpdateChildChannelsCommand.subscribeToNewChannels(UpdateChildChannelsCommand.java:146)

	... 62 more

Comment 4 Mike McCune 2007-03-21 01:10:30 UTC
problem is we aren't filtering non-compatible channels.

Comment 6 Bret McMillan 2007-03-26 15:00:36 UTC
Prad says he has provided this via irc, moving back to assigned...

Comment 7 Mike McCune 2007-03-28 17:03:42 UTC
TESTPLAN:

1) Register i386 server to RHN (assume rhel5-server)
2) Create a custom child channel from rhel5-server.  Make sure the Channel Arch
of this server is x86_64 and NOT IA-32
3) Go to the System's Channel Subscription page:

/rhn/systems/details/SystemChannels.do?sid=***********

4) Verify you see the custom channel in the list but its checkbox is greyed out.
5) Verify the custom channel indicates (unlimited) next to it.


Comment 8 Mike McCune 2007-03-28 17:05:20 UTC
Commited rev 113993 to RELEASE-5.0.1-hosted



Comment 9 Mike McCune 2007-04-02 15:21:25 UTC
onqa

Comment 10 Preethi Thomas 2007-04-03 14:56:33 UTC
verified. 4/3

Comment 11 Preethi Thomas 2007-05-10 16:01:21 UTC
The original issue seems to have been resolved in stage as well.

But following the test plan in comment#7 did not behave as expected. Opening a
new bug for that and maeking this one release-pending.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239699

Comment 12 Brandon Perkins 2007-05-17 02:20:43 UTC
Closed for RHN 501 Hosted.


Note You need to log in before you can comment on or make changes to this bug.