Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232643 - AVC on bootup: read access to /dev/random?
Summary: AVC on bootup: read access to /dev/random?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 14:30 UTC by Tom London
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 14:36:50 UTC


Attachments (Terms of Use)

Description Tom London 2007-03-16 14:30:41 UTC
Description of problem:

type=AVC msg=audit(1174054492.520:9): avc:  denied  { read } for  pid=2525
comm="automount" name="random" dev=tmpfs ino=3098
scontext=system_u:system_r:automount_t:s0
tcontext=system_u:object_r:random_device_t:s0 tclass=chr_file
type=SYSCALL msg=audit(1174054492.520:9): arch=40000003 syscall=5 success=no
exit=-13 a0=2ff243 a1=0 a2=2f7730 a3=812ac280 items=0 ppid=2524 pid=2525
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) comm="automount" exe="/usr/sbin/automount"
subj=system_u:system_r:automount_t:s0 key=(null)
type=AVC msg=audit(1174054492.520:10): avc:  denied  { read } for  pid=2530
comm="automount" name="random" dev=tmpfs ino=3098
scontext=system_u:system_r:automount_t:s0
tcontext=system_u:object_r:random_device_t:s0 tclass=chr_file
type=SYSCALL msg=audit(1174054492.520:10): arch=40000003 syscall=5 success=no
exit=-13 a0=dd6243 a1=0 a2=dce730 a3=812ac808 items=0 ppid=2524 pid=2530
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) comm="automount" exe="/usr/sbin/automount"
subj=system_u:system_r:automount_t:s0 key=(null)

Version-Release number of selected component (if applicable):
autofs-5.0.1-5



How reproducible:
every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Moyer 2007-03-16 14:38:45 UTC
Dan,

Autofs has an option for supporting a random multimount selection scheme. 
Because of this, we seed the random function with /dev/random at daemon startup.
 So, can you modify the policy accordingly?  Should this be reassigned to policy?


Comment 2 Daniel Walsh 2007-03-19 20:21:17 UTC
Fixed in selinux-policy-2.5.8-8.fc7


Note You need to log in before you can comment on or make changes to this bug.