Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232632 - GDM isn't launched [NEEDINFO]
Summary: GDM isn't launched
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 14:08 UTC by Charles A. Landemaine
Modified: 2014-06-02 13:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:06:23 UTC
pm-rhel: needinfo? (landemaine)


Attachments (Terms of Use)
/var/log/messages (deleted)
2007-03-19 22:19 UTC, Charles A. Landemaine
no flags Details
/var/log/messages (deleted)
2007-03-20 15:05 UTC, Charles A. Landemaine
no flags Details

Description Charles A. Landemaine 2007-03-16 14:08:34 UTC
I installed the Gnome desktop but after booting the system, I don't see GDM, I 
see a terminal prompt instead.

Comment 1 Ray Strode [halfline] 2007-03-19 13:55:53 UTC
what does

 /sbin/runlevel 

report?

Also does /etc/inittab say

id:5:initdefault:

or

id:3:initdefault:

?

If make it say the first thing, then do things work?

Comment 2 Charles A. Landemaine 2007-03-19 14:49:55 UTC
Ok, here's more info:

# /sbin/runlevel
N 5
#

Also, /etc/inittab says "id:5:initdefault:"
I get a black and white prompt screen, like a web server terminal.

Comment 3 Ray Strode [halfline] 2007-03-19 15:10:17 UTC
If you wait 2 minutes does it eventually come up?

If you press ctrl-alt-f7 does it bring you to the graphical display?

what is the output of ps -ef | grep gdm ?

How about 

rpm -q gdm ?
rpm -qV gdm ?

Comment 4 Charles A. Landemaine 2007-03-19 15:28:52 UTC
Waiting 2 minutes doesn't bring up GDM, neither does hitting Ctrl-Alt-F7. 
Here's more info:

# ps-ef | grep gdm
root 2236 2174 0 12:28 tty1 00:00:00 grep gdm
# rpm -q gdm
S.5....T c /etc/gdm/custom.conf
# rpm -qV gdm
gdm-2.16.0-19.el5
#

But IIRC, I installed GDM after installing RHEL5, using YUM.

Comment 5 Ray Strode [halfline] 2007-03-19 18:10:45 UTC
can you attach /var/log/messages ?

if you run /usr/sbin/gdm manually as root does it start?

Comment 6 Charles A. Landemaine 2007-03-19 22:19:55 UTC
Created attachment 150441 [details]
/var/log/messages

Comment 7 Charles A. Landemaine 2007-03-19 22:22:40 UTC
If I run /usr/sbin/gdm as root, it does launch GDM. Above's the content of /var/
log/messages.

Comment 8 Ray Strode [halfline] 2007-03-20 03:26:35 UTC
can you attach your /etc/sysconfig/desktop file?

Also, can you open up /etc/gdm/custom.conf and add

Enable=true 

under the [debug] section, reboot, and reattach /var/log/messages ?

Comment 9 Charles A. Landemaine 2007-03-20 15:05:54 UTC
Created attachment 150490 [details]
/var/log/messages

This is the /var/log/messages file.

Comment 10 Charles A. Landemaine 2007-03-20 15:07:21 UTC
My /etc/sysconfig/desktop file is empty.

Comment 11 RHEL Product and Program Management 2014-03-07 13:38:06 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 12 RHEL Product and Program Management 2014-06-02 13:06:23 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.