Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232630 - Tap feature of touchpad not fully implemented [NEEDINFO]
Summary: Tap feature of touchpad not fully implemented
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: synaptics
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 14:05 UTC by Charles A. Landemaine
Modified: 2014-06-02 13:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:19:10 UTC
pm-rhel: needinfo? (landemaine)


Attachments (Terms of Use)
The original xorg.conf file (deleted)
2007-03-21 13:46 UTC, Charles A. Landemaine
no flags Details
The Xorg log file (deleted)
2007-03-21 13:47 UTC, Charles A. Landemaine
no flags Details
The Xorg log file after removing xorg.conf and rebooting (deleted)
2007-03-21 14:01 UTC, Charles A. Landemaine
no flags Details
xorg-log (deleted)
2008-05-15 16:18 UTC, Jonas Nyman
no flags Details
xorg.log (deleted)
2008-05-15 16:19 UTC, Michael A G Lacintra
no flags Details

Description Charles A. Landemaine 2007-03-16 14:05:35 UTC
I have an AlpsGlide Synaptics touchpad. The drag and drop feature doesn't work 
with my touchpad if I use it together with the tap feature. In other words, if 
I hit twice the touchpad without releasing it, over a file, and if I try 
dragging this file to a different directory, moving my finger over the 
touchpad, the file doesn't move to the other directory.

Comment 1 David Zeuthen 2007-03-16 17:07:40 UTC
Not sure why you filed this against nautilus-media; reassinging to Nautilus.
Btw, sounds like an X11 bug to me, not sure though, so I'll let Alex decide.

Comment 2 David Zeuthen 2007-03-16 17:14:42 UTC
Wrong CC

Comment 3 Alexander Larsson 2007-03-19 10:00:48 UTC
I have no idea what tap is supposed to do, but its nothing nautilus ever cares
explicitly about. Its likely an X issue or driver issue.

Comment 4 Charles A. Landemaine 2007-03-19 11:47:57 UTC
Please refer to the original message for explanations on what tap is supposed 
to do.

Comment 5 Matěj Cepl 2007-03-20 21:11:00 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 6 Charles A. Landemaine 2007-03-21 13:46:34 UTC
Created attachment 150572 [details]
The original xorg.conf file

Comment 7 Charles A. Landemaine 2007-03-21 13:47:36 UTC
Created attachment 150573 [details]
The Xorg log file

Comment 8 Charles A. Landemaine 2007-03-21 14:01:13 UTC
Created attachment 150575 [details]
The Xorg log file after removing xorg.conf and rebooting

After removing xorg.conf and rebooting, the tap feature of my touchpad still
doesn`t work.

Comment 9 Matěj Cepl 2007-03-21 20:31:24 UTC
It might be something so simple as improper configuration of your touchpad --
which doesn't make it less bug, because auto-detection should work -- but it
could be possible to overcome this bug by configuring it yourself.

Could you try to edit /etc/X11/xorg.conf (you have to be root to do it; and
don't forget to make a backup copy of the file) and add this new section to it?

Section "InputDevice"
	Identifier  "Touchpad"
	Driver      "synaptics"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

(your settings may differ, more details could be find in synaptics(5) manpage)
and then change the section "ServerLayout" (should be on the top of the file) so
that it refers to your new InputDevice. Like this (the only change should be the
one regarding your touchpad, left the rest as it is even if it differs from this
example):

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Touchpad" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Restart X and try it again. Does it help?

Comment 10 Charles A. Landemaine 2007-03-21 21:11:03 UTC
No, it still doesn't work. I didn't find any solution in the man page either.
The following line caused the touchpad to be very slow also:

InputDevice    "Touchpad" "CorePointer"

Comment 11 Hendrik Borghorst 2008-04-12 21:31:47 UTC
I can confirm it on Asus EEE-PC. Tapping is not working

Comment 12 Jonas Nyman 2008-05-15 16:18:22 UTC
Created attachment 305504 [details]
xorg-log

Comment 13 Michael A G Lacintra 2008-05-15 16:19:15 UTC
Created attachment 305505 [details]
xorg.log

Comment 14 RHEL Product and Program Management 2014-03-07 13:44:50 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 15 RHEL Product and Program Management 2014-06-02 13:19:10 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.