Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232602 - Kernel %prep should not modify files in SOURCES (patch included)
Summary: Kernel %prep should not modify files in SOURCES (patch included)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Don Zickus
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 11:50 UTC by Jos Vos
Modified: 2009-05-26 20:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-26 20:45:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch for kernel-2.6.spec (2.6.18-8.1.1.el5) (deleted)
2007-03-16 11:50 UTC, Jos Vos
no flags Details | Diff

Description Jos Vos 2007-03-16 11:50:01 UTC
Description of problem:
In %prep the *.config files from SOURCES are modified (merge.pl etc.) and the
original files are replaced by the modified ones! This is IMHO a serious RPM
packaging bug, as now (for example) the src.rpm files created with "rpmbuild
-bs" and  with "rpmbuild -ba" will have different contents (source files)!

Version-Release number of selected component (if applicable):
2.6.18-8.1.1.el5 (but this problem seems to be in since a while, sorry I didn't
notice it during the beta period ;-)).

How reproducible:
Compare the src.rpm's created with "rpmbuild -bs" and  with "rpmbuild -ba".

Solution:
Modify the *.config files in the build directory, don't change the files in
SOURCES.  Attached is a patch for the kerrnel spec file that does this.  Note
that the wildcards will not always match files now, that's why I included the
test (-f), so that if there is no match, the "$i" will still have the "*" and
the file does not exist.

Comment 1 Jos Vos 2007-03-16 11:50:01 UTC
Created attachment 150212 [details]
Patch for kernel-2.6.spec (2.6.18-8.1.1.el5)

Comment 2 Don Zickus 2007-06-21 04:59:54 UTC
Thanks.  It's been like that for about a year now.  We just have never noticed.
 I'll look into making these changes for 5.2.  They look straightforward.

-Don



Comment 3 Jarod Wilson 2007-07-11 17:59:42 UTC
Funny, I just started work on a patch for the rawhide spec last night that does
a lot of the same things... :) Yeah, those changes definitely look sane and
correct for the RHEL5 spec.

Comment 4 Don Zickus 2008-01-11 20:04:45 UTC
in 2.6.18-66.el5dz_test
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 5 Don Zickus 2009-05-26 20:45:56 UTC
This should have went out with the 5.2 release.  I am just going to close this a CURRENT RELEASE unless someone has a better idea.


Note You need to log in before you can comment on or make changes to this bug.