Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232601 - Delete key acting as backspace
Summary: Delete key acting as backspace
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 11:48 UTC by Tomas Janousek
Modified: 2014-07-29 11:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 11:01:13 UTC


Attachments (Terms of Use)

Description Tomas Janousek 2007-03-16 11:48:03 UTC
Description of problem:
The delete key works as backspace in the bottom-line -- like when editing the
subject etc.


Version-Release number of selected component (if applicable):
mutt-1.5.14-1.fc7 (and all the other mutt versions i've ever seen)


How reproducible:
Run mutt in xterm/rxvt/linux console, type 'm', type something, move the cursor
to the middle of the line and press delete.


Actual results:
The char on the left side of the cursor is deleted.


Expected results:
The char under the cursor should be deleted.

Comment 1 Miroslav Lichvar 2007-03-19 11:33:19 UTC
Ok, the config file in mutt-1.5.14-2.fc7 has the correct binding.

Comment 2 jpacner 2014-07-23 14:07:56 UTC
List of patches present on mutt-1.5.20-6.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=bbd5b6c6d94587519ccb3513d6fbebc8ef104de4

Comment 3 jpacner 2014-07-29 11:01:13 UTC
Recovering from unwanted changes caused by a badly chosen bug number choice.


Note You need to log in before you can comment on or make changes to this bug.