Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232590 - ImportError: No module named elementtree.SimpleXMLWriter
Summary: ImportError: No module named elementtree.SimpleXMLWriter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: repoview
Version: 7
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Konstantin Ryabitsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 242803 247319 (view as bug list)
Depends On:
Blocks: FE7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-16 09:49 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version: 0.5.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-06 18:13:30 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2007-03-16 09:49:46 UTC
$ repoview .
Traceback (most recent call last):
  File "/usr/bin/repoview", line 40, in <module>
    from elementtree.SimpleXMLWriter import XMLWriter
ImportError: No module named elementtree.SimpleXMLWriter

$ rpm -q repoview
repoview-0.5.2-1.fc6

$ cat /etc/fedora-release 
Fedora release 6.91 (Rawhide)

Comment 1 Stephanos Manos 2007-06-04 22:57:37 UTC
seems python-elementtree was dropped from f7.
recompiling the fc6 rpm fixes it.

Comment 2 Michael Schwendt 2007-06-04 23:00:07 UTC
@ Stephanos Manos

It is a run-time failure. Rebuilding the src.rpm cannot fix it.

Comment 3 Stephanos Manos 2007-06-04 23:08:50 UTC
I forgot to add "and installing it (the python-elementtree)"



Comment 4 Takanori MATSUURA 2007-06-05 00:42:48 UTC
I think the core components of elementtree are included in python-2.5 and
python-elementtree package is disappeared from F7.
http://effbot.org/zone/element-index.htm


Comment 5 Michael Schwendt 2007-06-05 09:05:37 UTC
Hence this bug report. What has been merged into Python 2.5 is not
equal to what used to be in the python-elementtree package.


Comment 6 Takanori MATSUURA 2007-06-05 09:56:09 UTC
According to the Python-Del ML, XMLWriter was left out.
http://mail.python.org/pipermail/python-dev/2006-August/068224.html

Comment 7 Konstantin Ryabitsev 2007-06-05 23:19:05 UTC
*** Bug 242803 has been marked as a duplicate of this bug. ***

Comment 8 Till Maas 2007-06-27 20:11:22 UTC
Is anyone working on this? This Bug renders the repoview package completely
useless, because it does not do anything.

Comment 9 Till Maas 2007-06-27 20:22:24 UTC
I filled a bug request in upstream's bugzilla:

https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=755

Comment 10 Konstantin Ryabitsev 2007-06-28 13:56:00 UTC
I will backport a fix for F-7 from the trunk. Sorry, the new version that was
supposed to fix this is taking longer than I had expected.

Comment 11 Konstantin Ryabitsev 2007-06-29 15:32:51 UTC
Cumulative patch for F7:
http://mricon.com/trac/changeset/352

The fixed version will show up in F7-testing soon.

Comment 12 Fedora Update System 2007-07-02 16:06:08 UTC
repoview-0.5.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2007-07-06 18:13:26 UTC
repoview-0.5.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Konstantin Ryabitsev 2007-07-06 23:27:11 UTC
*** Bug 247319 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.