Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232584 - Kernel 2.6.20-1.2925.fc6 does not correctly detect PCI Bridge
Summary: Kernel 2.6.20-1.2925.fc6 does not correctly detect PCI Bridge
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 08:27 UTC by Daniel Duggan
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 19:53:11 UTC


Attachments (Terms of Use)
/sbin/lspci -t /sbin/lspci | grep -i nvidia uname -r 2.6.20-1.2925.fc6 (deleted)
2007-03-16 08:27 UTC, Daniel Duggan
no flags Details
Working and Not Working Dmesg (deleted)
2007-03-19 23:58 UTC, Daniel Duggan
no flags Details
Dmesg from 2.6.20 Kernel booted with pci=nocommf with and without SLI enabled (deleted)
2007-03-23 02:26 UTC, Daniel Duggan
no flags Details
dmesg and xorg.0.log from 2944 i686 kernel (deleted)
2007-04-14 03:10 UTC, Daniel Duggan
no flags Details
xorg.0.log 2944 i686 kernel (deleted)
2007-04-14 03:11 UTC, Daniel Duggan
no flags Details
Dmesg and xorg without SLI (deleted)
2007-04-16 06:15 UTC, Daniel Duggan
no flags Details
Dmesg and xorg with SLI (deleted)
2007-04-16 06:16 UTC, Daniel Duggan
no flags Details

Description Daniel Duggan 2007-03-16 08:27:45 UTC
Description of problem:
Kernel 2.6.20-1.2925.fc6 does not properly detect the PCI Bridge in order to
successfully configure SLI
This is a regression from previous kernels ... SLI has worked fine with most if
not all kernels since 2.17
Version-Release number of selected component (if applicable):
2.6.20-1.2925.fc6 

How reproducible:
100 %

Steps to Reproduce:
1.Boot with SLI enabled
2.
3.
  
Actual results:
The kernel does not properly detect the PCI bridge and therefore the 
X server will not start .. black screen mouse is active

Expected results:
The kernel should properly detect the PCI bridge

Additional info:
2 Nvidia  [GeForce 7800 GTX]
Not a driver issue as far as I can determine as the same failure occurs whether
I use the nv or kmod-nvida from the Livna repo

When SLI is disabled the boot, login and the successful start of the Xserver
works as expected.

Comment 1 Daniel Duggan 2007-03-16 08:27:45 UTC
Created attachment 150201 [details]
/sbin/lspci -t    /sbin/lspci | grep -i nvidia  uname -r
2.6.20-1.2925.fc6

Comment 2 Chuck Ebbert 2007-03-16 15:01:06 UTC
Output of "rpm -qa | grep nvidia" does not show the
driver for kernel 2925. If you have both 2911.6.5
and 2925 kernels installed, you should see:

$ rpm -qa | grep nvidia
kmod-nvidia-1.0.9755-2.2.6.20_1.2925.fc6
kmod-nvidia-1.0.9755-2.2.6.19_1.2911.6.5.fc6
xorg-x11-drv-nvidia-1.0.9755-3.lvn6


Comment 3 Daniel Duggan 2007-03-17 11:41:01 UTC
Hello:
My mistake as I failed to include that :)

#rpm -qa | grep nvidia
xorg-x11-drv-nvidia-1.0.9755-3.lvn6
kmod-nvidia-1.0.9755-2.2.6.19_1.2911.6.5.fc6
kmod-nvidia-1.0.9755-2.2.6.20_1.2925.fc6

Dan

Comment 4 Daniel Duggan 2007-03-18 06:42:39 UTC
The kernel 2.6.20-1.2925.fc6 can be successfully booted with SLI enabled when I
boot with
pci=nommconf added as a parameter.

Dan

Comment 5 Dave Jones 2007-03-19 19:37:23 UTC
please attach a dmesg output from a working and non-working kernel
(note: attach, not paste into comments :)

Comment 6 Daniel Duggan 2007-03-19 23:58:08 UTC
Created attachment 150445 [details]
Working and Not Working Dmesg

Hello:
Both were created with SLI enabled [/etc/X11/xorg.conf] and without any desktop
effects enabled

Dan

Comment 7 Daniel Duggan 2007-03-20 01:07:50 UTC
Hello:
Just some additional information, hopefully it helps as I am not all that
technical and somewhat confused ?
With SLI enabled, the same xorg.conf and the same nViida drivers:
And no desktop effects enabled [compiz or beryl] everything appears to work
correctly and as expected.  This is the same with both the 2.6.19 and 2.6.20
kernels.

With desktop effects enabled [compiz or beryl] the 2.6.19 kernel works as
expected. However, the 2.6.20 kernel will not launch a usable DE [Gnome, KDE or
XFCE]
If SLI is disabled the 2.6.20 kernel works fine with desktop effects [compiz or
beryl] enabled ?
SLI and whether it is enabled or disabled, seems to be the only variable I can
track down 

Regards

Dan


Comment 8 Chuck Ebbert 2007-03-20 18:17:12 UTC
Can you post the log from working 2.6.20 (with pci=nommconf) ?



Comment 9 Daniel Duggan 2007-03-23 02:26:14 UTC
Created attachment 150718 [details]
Dmesg from 2.6.20 Kernel booted with pci=nocommf with and without SLI enabled

Comment 10 Daniel Duggan 2007-03-23 05:42:14 UTC
Hello:
I just wanted to add that with pci=nommconf it may or may not boot correctly to
the Desktop with SLI enabled.
It's about a 50/50 chance.

Dan

Comment 11 Daniel Duggan 2007-03-24 00:26:09 UTC
Hello:
Exactly the same issue with the latest kernel 2.6.20-1.2933.fc6 and same nVidia
kmod-nvidia drivers

Dan

Comment 12 Daniel Duggan 2007-04-14 03:10:38 UTC
Created attachment 152601 [details]
dmesg and xorg.0.log from 2944 i686 kernel

Comment 13 Daniel Duggan 2007-04-14 03:11:58 UTC
Created attachment 152602 [details]
xorg.0.log 2944 i686 kernel

Comment 14 Daniel Duggan 2007-04-14 03:16:07 UTC
Comment on attachment 152601 [details]
dmesg and xorg.0.log from 2944 i686 kernel

Hello:
Thanks folks.

It appears that the changes made to the 2944 kernel have fixed the issue.
2.6.20-1.2944.fc6 i686
kmod-nvidia-1.0.9755-2.2.6.20_1.2944.fc6

Dan

Comment 15 Daniel Duggan 2007-04-16 06:15:46 UTC
Created attachment 152666 [details]
Dmesg and xorg without SLI

Comment 16 Daniel Duggan 2007-04-16 06:16:39 UTC
Created attachment 152667 [details]
Dmesg and xorg with SLI


Note You need to log in before you can comment on or make changes to this bug.