Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232547 - dmraid section fails to find sata raid devices after upgrade from kernel 2.6.19-1.2911.6.5 to 2.6.20-1.2925
Summary: dmraid section fails to find sata raid devices after upgrade from kernel 2.6....
Keywords:
Status: CLOSED DUPLICATE of bug 232600
Alias: None
Product: Fedora
Classification: Fedora
Component: dmraid
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 01:45 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-22 19:42:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2007-03-16 01:45:55 UTC
Description of problem:
Specifically, I have a Promise FastTrak 376 controller (20376) controller with a
Parallel IDE hard drive connected using the PATA/IDE port of this otherwise SATA
controller. The controller is in the 'sda' position with a logical partition in
sda5.
  
Prior to upgrading from kernel 2.6.19 to 2.6.20, the rc.sysinit script was able
to setup the device [though as indicated in the bug I reported (216078) back in
November, I needed to manually add the line 'dmraid.static -ay -i' to rc.sysinit
to set up the partition (pdc_ccdejaib5)].

Now not only is the partition not created but the device itself is not
recognized so I cannot mount the disk.

Specifically,
BEFORE (kernel 2.6.19)
1] ls -al /dev/mapper, returns:
      crw-------  1 root root  10, 63 Mar 15 17:36 control
      brw-rw----  1 root disk 253,  0 Mar 15 21:36 pdc_ccdejaib
      brw-rw----  1 root disk 253,  1 Mar 15 21:36 pdc_ccdejaib5

2]Running: /sbin/dmsetup ls --target multipath --exec "/sbin/kpartx -a -p p" 
  executes with error
3]Running: /sbin/dmraid.static -ay -i -v
  returns:

       RAID set "pdc_ccdejaib" already active
       INFO: Activating stripe RAID set "pdc_ccdejaib"
       RAID set "pdc_ccdejaib5" already active
       INFO: Activating partition RAID set "pdc_ccdejaib5"

NOW (kernel 2.6.20):
1] ls -al /dev/mapper, returns:
       crw------- 1 root root 10, 63 Mar 15 16:18 control

2]Running: /sbin/dmsetup ls --target multipath --exec "/sbin/kpartx -a -p p" 
  returns:
      No devices found
3]Running: /sbin/dmraid.static -ay -i -v
  returns:
      No RAID disks
Of course 'fdisk -l' then no longer recognizes the /dev/sda device and I am not
able to mount that drive anymore.

Not sure if this is relevant, but both before under kernel 2.6.19 and now under
2.6.20, the kernel logs the following error message:

 kernel: device-mapper: ioctl: 4.x.0-ioctl (2006-mm-dd) initialised:
dm-devel@redhat.com
    kernel: device-mapper: table: 253:0: linear: dm-linear: Device lookup failed
    kernel: device-mapper: ioctl: error adding target to table

I also noticed that under kernel 2.6.19, the version was 4.10.0, while the
version under 2.6.20 is 4.11.0 -- did anything change here?

So, in summary, any idea what happened between 2.6.19 and 2.6.20 that 'broke'
dmraid for me?

How reproducible:
Every time :(

Comment 1 Need Real Name 2007-03-16 15:03:35 UTC
One other note, the kernel still seems to be recognizing the Promise 20376
controller itself, since both under kernels 2.6.19 and 2.6.20, lspci -v returns:

02:04.0 RAID bus controller: Promise Technology, Inc. PDC20376 (FastTrak 376)
(rev 02)
        Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
        Flags: bus master, 66MHz, medium devsel, latency 96, IRQ 19
        I/O ports at b400 [size=64]
        I/O ports at b000 [size=16]
        I/O ports at a800 [size=128]
        Memory at eb800000 (32-bit, non-prefetchable) [size=4K]
        Memory at eb000000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [60] Power Management version 2

Comment 2 Need Real Name 2007-03-16 15:16:52 UTC
Some more detail:
'dmsetup -C info' returns:
    No devices found

lsmod shows that the sata_promise module is loaded...

So not sure what is going on here but somehow the kernel recognizes the Promise
FastTrak controller but dmsetup/dmraid don't see any devices...

Again, it all works perfectly on the same system if I instead boot into my old
kernel 2.6.19

Comment 3 Need Real Name 2007-03-22 19:41:36 UTC
Bug is addressed under:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232600

Comment 4 Need Real Name 2007-03-22 19:42:33 UTC

*** This bug has been marked as a duplicate of 232600 ***


Note You need to log in before you can comment on or make changes to this bug.