Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232533 - [rhel4.5] The version.h has no define to find out the release and update.
Summary: [rhel4.5] The version.h has no define to find out the release and update.
Keywords:
Status: CLOSED DUPLICATE of bug 232526
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Konrad Rzeszutek
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 00:21 UTC by Konrad Rzeszutek
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-05 18:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch against the Makefile. (deleted)
2007-03-16 00:21 UTC, Konrad Rzeszutek
no flags Details | Diff
Patch against the spec file. (deleted)
2007-03-16 00:22 UTC, Konrad Rzeszutek
no flags Details | Diff

Description Konrad Rzeszutek 2007-03-16 00:21:17 UTC
Description of problem:

When compiling modules against the kernel, there is no easy way to determine
what release and update the kernel is.

Comment 1 Konrad Rzeszutek 2007-03-16 00:21:17 UTC
Created attachment 150185 [details]
Patch against the Makefile.

Comment 2 Konrad Rzeszutek 2007-03-16 00:22:50 UTC
Created attachment 150187 [details]
Patch against the spec file.

and the patch against the spec file. The redhat_release_minor would have to be
changed every release.

Comment 3 RHEL Product and Program Management 2007-03-20 16:44:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 John Jarvis 2007-03-23 19:06:07 UTC
*** Bug 146499 has been marked as a duplicate of this bug. ***

Comment 7 John Jarvis 2007-03-24 01:13:30 UTC
This enhancement request was evaluated by the full Red Hat Enterprise Linux team
for inclusion in a Red Hat Enterprise Linux minor release.   As a result of this
evaluation, Red Hat has tentatively approved inclusion of this feature in the
next Red Hat Enterprise Linux Update minor release.   While it is a goal to
include this enhancement in the next minor release of Red Hat Enterprise Linux,
the enhancement is not yet committed for inclusion in the next minor release
pending the next phase of actual code integration and successful Red Hat and
partner testing.

Comment 8 Konrad Rzeszutek 2007-03-29 20:24:07 UTC
Patch has been posted to RHKL.

Comment 9 Konrad Rzeszutek 2007-04-05 17:34:12 UTC
Patch is in 2.6.9-53 kernel.

Comment 10 John Jarvis 2007-04-05 18:21:13 UTC
Closing as dupe of RHBZ 232526.  This should be in the next snapshot (#6).

*** This bug has been marked as a duplicate of 232526 ***

Comment 11 John Jarvis 2007-04-05 18:28:25 UTC
To further clarify, this feature is being delivered in RHEL 4.5 so closing the
request for RHEL 4.6


Note You need to log in before you can comment on or make changes to this bug.