Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232512 - "Add additional software repositories" button tries to DHCP again
Summary: "Add additional software repositories" button tries to DHCP again
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
: 234263 235814 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-03-15 20:16 UTC by Adam Jackson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 19:43:07 UTC


Attachments (Terms of Use)

Description Adam Jackson 2007-03-15 20:16:59 UTC
You DHCP once in stage1.  Click the additional repos button in stage 2, and
it'll prompt you to make sure you have a working network connection, and try to
DHCP on the same NIC again.  Then it'll hang forever.

Should probably check if the NIC is already up and skip the prompt if so.

Comment 1 Will Woods 2007-03-27 23:24:25 UTC
Still happening in anaconda-11.2.0.40-2 (today's rawhide and the current Test3
candidate tree). 

In fact, if you hit the "Add additional software repositories" button while
doing an NFS install, we appear to lose the NFS server and hang completely.

The last anaconda log lines are:
moving (1) to step reposetup
moving (1) to step basepkgsel
moving (1) to step tasksel

The last system log lines are the nic going down and coming back up, and then:
nfs: server hostname.localdomain not responding, still trying

and that's it.

Comment 2 David Cantrell 2007-03-28 14:54:16 UTC
*** Bug 234263 has been marked as a duplicate of this bug. ***

Comment 3 David Cantrell 2007-04-11 17:12:35 UTC
*** Bug 235814 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.