Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232511 - Anaconda dies with its own generated kickstart file
Summary: Anaconda dies with its own generated kickstart file
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-15 20:14 UTC by Juan Quintela
Modified: 2008-05-07 01:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-05-07 01:17:46 UTC

Attachments (Terms of Use)
my kickstart file (deleted)
2007-03-15 20:14 UTC, Juan Quintela
no flags Details
anaconda stack trace (deleted)
2007-03-15 20:20 UTC, Juan Quintela
no flags Details

Description Juan Quintela 2007-03-15 20:14:04 UTC
Description of problem:

Using the anaconda-ks.cfg generated file by anaconda install launchs one
exception.  Problem is the partitioning code.

part /boot --fstype ext3 --size=100 --ondisk=xvda
part pv.2 --size=0 --grow --ondisk=xvda
volgroup VolGroup00 --pesize=32768 pv.2
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=352 --grow
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow

I have tried with values of --size={10,100,1500} as suggested by clummens.  It
produces the same problem.

Version-Release number of selected component (if applicable):

Fedora Rawhide

How reproducible:

It happens always

Steps to Reproduce:
1. Try to install using a kickstart file form a previous installation.  I am
attaching mine.
2. Install using the kickstart file.
Actual results:

Python stack trace during install.

Expected results:

Kickstart working and partitioning the disk correctly.  Notice that this
configuration has worked for FC5/FC6/RHEL5.  And it is the hint that anaconda
itself gives (still in current rawhide).

Additional info:

That values are the ones that anaconda generates when I select it to
autopartition my disk (it is a 4GB disk).  There is no better way (that I know)
of generating it.

Comment 1 Juan Quintela 2007-03-15 20:14:04 UTC
Created attachment 150168 [details]
my kickstart file

Comment 2 Juan Quintela 2007-03-15 20:20:52 UTC
Created attachment 150169 [details]
anaconda stack trace

Comment 3 Matthew Miller 2007-04-10 16:35:58 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 4 Bug Zapper 2008-04-03 23:41:37 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 5 Bug Zapper 2008-05-07 01:17:44 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.