Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232502 - Kickstart fails to partition disk, installation fails
Summary: Kickstart fails to partition disk, installation fails
Keywords:
Status: CLOSED DUPLICATE of bug 232936
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 19:32 UTC by Steve Magoun
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 20:49:27 UTC


Attachments (Terms of Use)
Anaconda log from failed installation (deleted)
2007-03-15 19:32 UTC, Steve Magoun
no flags Details
syslog (deleted)
2007-03-15 19:33 UTC, Steve Magoun
no flags Details
kickstart file (deleted)
2007-03-15 19:35 UTC, Steve Magoun
no flags Details

Description Steve Magoun 2007-03-15 19:32:37 UTC
Description of problem:
I'm trying to kickstart F7T2 by booting off the F7T2 DVD, with my ks.cfg file on a floppy. Anaconda 
silently fails to partition my disk, and not surprisingly installation later fails when it can't mount any 
partitions.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.2-1.fc7.noarch.rpm
anaconda-11.2.0.26-1.i386.rpm
anaconda-runtime-11.2.0.26-1.i386.rpm


How reproducible:
Always


Steps to Reproduce:
1. Create ks.cfg using system-config-kickstart.
2. Boot system off F7T2 DVD, use 'linux ks=floppy' at the boot: prompt 
  
Actual results:
Installation starts, but eventually stops with the error "An error occurred trying to initialize swap on 
device sda2. This problem is serious, and the install cannot continue."

Hitting Alt-F5 shows a console with the message, "/tmp/sda2: No such device or address"

After the error appears, 'fdisk -l /dev/sda' (run from the shell in Alt-F2) shows no partitions at all on 
the disk. From the shell, partitioning the disk by hand seems to work correctly.


Expected results:
Disk is partitioned correctly, kickstart installation completes normally.


Additional info:
My system is a development board with an AMD Geode LX 800. The disk is a 1.8" IDE disk (Toshiba 
MK2004GAL). We use the system for kickstarting FC4 with no trouble.

Interactive installation works fine, it seems like just kickstart installs are broken.

I've seen this problem in qemu as well. Qemu lets you use a raw disk (launch with '-hda /dev/sdb') or a 
disk image; the problem occurs with both raw disk and the image.

Comment 1 Steve Magoun 2007-03-15 19:32:37 UTC
Created attachment 150162 [details]
Anaconda log from failed installation

Comment 2 Steve Magoun 2007-03-15 19:33:36 UTC
Created attachment 150163 [details]
syslog

Comment 3 Steve Magoun 2007-03-15 19:35:51 UTC
Created attachment 150164 [details]
kickstart file

Kickstart file with root password removed. I've tried a number of different
combinations of use existing partitions/create new ones, clobber/don't clobber
the MBR, etc. None of them have made a difference. Removing the swap partition
(so it's just / and /boot) doesn't make a difference.

Comment 4 David Cantrell 2007-03-27 20:49:27 UTC

*** This bug has been marked as a duplicate of 232936 ***


Note You need to log in before you can comment on or make changes to this bug.