Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232463 - Unable to boot : kernel panic with kernel 2.6.20-1.2925.fc6
Summary: Unable to boot : kernel panic with kernel 2.6.20-1.2925.fc6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 17:04 UTC by Paul Ezvan
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-15 12:17:07 UTC


Attachments (Terms of Use)
initrd (deleted)
2007-03-15 18:16 UTC, Paul Ezvan
no flags Details

Description Paul Ezvan 2007-03-15 17:04:57 UTC
Description of problem:
When starting the system with kernel 2.6.20-1.2925.fc6, I get these errors :
insmod : error inserting '/lib/ext3.ko':-1 Unknown symbole in module
insmod : error inserting '/lib/sata_sil.ko':-1 Unknown symbole in module
insmod : error inserting '/lib/sata_nv.ko':-1 Unknown symbole in module

And then I get a kernel panic because it cannot mount the filesystems.

Version-Release number of selected component (if applicable):
kernel 2.6.20-1.2925.fc6

How reproducible:
A each boot

Steps to Reproduce:
1.Boot with kernel 2.6.20-1.2925.fc6
2.
3.
  
Actual results:
kernel panic, no filesystem mounted ( LVM unable to access to hard disk
connected on the silicon image sata RAID controler )

Expected results:


Additional info:

Comment 1 Chuck Ebbert 2007-03-15 18:02:44 UTC
What version of mkinitrd do you have?

Can you post your initrd file?


Comment 2 Paul Ezvan 2007-03-15 18:16:14 UTC
Created attachment 150147 [details]
initrd

Comment 3 Paul Ezvan 2007-03-15 18:21:51 UTC
(In reply to comment #1)
> What version of mkinitrd do you have?
> 
> Can you post your initrd file?
> 
mkinitrd-5.1.19.0.3-1

Comment 4 Chuck Ebbert 2007-03-15 18:34:52 UTC
Where did that mkinitrd come from?

Latest I can find is 5.1.19.0.2-1


Comment 5 Paul Ezvan 2007-03-15 18:41:49 UTC
It came from updates.

Comment 6 Chuck Ebbert 2007-03-16 17:29:22 UTC
Something is seriously wrong with your kernel dependencies file.
I would first try uninstalling and then reinstalling the kernel.

Also please post contents of your /etc/modprobe.conf.



Comment 7 Paul Ezvan 2007-03-16 18:18:56 UTC
(In reply to comment #6)
> Something is seriously wrong with your kernel dependencies file.
> I would first try uninstalling and then reinstalling the kernel.
> 
> Also please post contents of your /etc/modprobe.conf.
> 
> 
I tried it twice, but it doesn't change anything.

Here is my /etc/modprobe.conf :
alias eth0 r8169
alias eth1 forcedeth
alias scsi_hostadapter sata_sil
alias scsi_hostadapter1 sata_nv
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0 
options snd-intel8x0 index=0 
options snd-pcm-oss dsp_map=2 adsp_map=2 
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias snd-card-2 quickcam_messenger
options snd-card-2 index=2 
options quickcam_messenger index=2 
remove quickcam_messenger { /usr/sbin/alsactl store 2 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove quickcam_messenger
# I2C module options
alias char-major-89 i2c-dev



Comment 8 Dave Jones 2007-03-19 19:14:09 UTC
For some reason libata.ko, sd_mod.ko and scsi_mod.ko are missing from your initrd.

It's almost as if it decided to ignore all the dependancies.
Peter, any ideas why mkinitrd would do that ?

Comment 9 Peter Jones 2007-03-22 21:33:43 UTC
Well, we only pull in sd_mod if we see scsi_mod being pulled in, because there's
no real dependency there, but I don't know why the others wouldn't be pulled in.

Paul, if you run these commands, what do they print:

modprobe --set-version 2.6.20-1.2925.fc6 --show-depends ext3
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_sil
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_nv

And once you've done that, could you also do:

depmod -a 2.6.20-1.2925.fc6
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends ext3
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_sil
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_nv


Comment 10 Paul Ezvan 2007-03-22 23:53:31 UTC
# modprobe --set-version 2.6.20-1.2925.fc6 --show-depends ext3
FATAL: Could not load /lib/modules/2.6.20-1.2925.fc6/modules.dep: No such file
or directory
# modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_sil
FATAL: Could not load /lib/modules/2.6.20-1.2925.fc6/modules.dep: No such file
or directory
# modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_nv
FATAL: Could not load /lib/modules/2.6.20-1.2925.fc6/modules.dep: No such file
or directory

# depmod -a 2.6.20-1.2925.fc6
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends ext3
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/fs/jbd/jbd.ko 
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/fs/ext3/ext3.ko
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_sil
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/scsi/scsi_mod.ko 
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/ata/libata.ko 
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/ata/sata_sil.ko
modprobe --set-version 2.6.20-1.2925.fc6 --show-depends sata_nv
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/scsi/scsi_mod.ko 
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/ata/libata.ko 
insmod /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/ata/sata_nv.ko 


Comment 11 Chuck Ebbert 2007-03-23 21:51:35 UTC
You should be able to boot if you make a new initrd now that depmod
has created the dependency information.



Comment 12 Paul Ezvan 2007-03-23 21:57:23 UTC
It is what I thought but unfortunately I get the same error when I try to boot
with kernel 2-6-20-1.2925.fc6.

Comment 13 Chuck Ebbert 2007-03-23 22:14:27 UTC
Did you make the new initrd correctly? It will default to building
one for your current kernel.

mkinitrd <file name> <kernel version>

mkinitrd /boot/initrd-2.6.20-1.2925.fc6.img 2.6.20-1.2925.fc6

Comment 14 Paul Ezvan 2007-03-24 10:13:53 UTC
No, I did not do it. After doing it, it works.
I have got the same problem with the new kernel update.
Yum says that it can not write /boot/System.map-2.6.20-1.2933.fc6 due to an
access error.
In /var/log/messages I get :
Mar 24 10:48:26 gen2 kernel: audit(1174729706.929:4): avc:  denied  { search }
for  pid=3923 comm="depmod" name="/" dev=hdb1 ino=2
scontext=user_u:system_r:depmod_t:s0 tcontext=system_u:object_r:file_t:s0 tclass=dir
Mar 24 10:48:37 gen2 kernel: end_request: I/O error, dev fd0, sector 0
Mar 24 10:48:38 gen2 Installed: kernel.i686 2.6.20-1.2933.fc6


Comment 15 Paul Ezvan 2007-03-24 17:00:06 UTC
(In reply to comment #14)
The exact message given by yum is : "FATAL: Could not open
'/boot/System.map-2.6.20-1.2933.fc6': Permission denied"

Comment 16 Chuck Ebbert 2007-04-19 21:15:16 UTC
I think the filesystem needs to be relabeled when these access errors happen.


Comment 17 Paul Ezvan 2007-04-19 22:09:19 UTC
The boot partition's label is "/boot", what label should I set ?

Comment 18 Chuck Ebbert 2007-04-19 23:05:51 UTC
Filesystem relabeling is an selinux operation.
Create a file called /.autorelabel and reboot to start the
relabel. It could take a while.


Comment 19 Paul Ezvan 2007-06-15 12:16:37 UTC
It fixed the problem. Thank you.


Note You need to log in before you can comment on or make changes to this bug.