Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232458 - dd reports false statistics in hu_HU.UTF-8 locale
Summary: dd reports false statistics in hu_HU.UTF-8 locale
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 16:36 UTC by Gergely Gábor
Modified: 2007-12-17 09:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-17 09:56:21 UTC


Attachments (Terms of Use)

Description Gergely Gábor 2007-03-15 16:36:01 UTC
Description of problem:

false stats are returned after a run of dd in the hu_HU.UTF-8 locale.


Version-Release number of selected component (if applicable):
coreutils-5.97-12.3.fc6

How reproducible:
always:

Steps to Reproduce:
1. use dd
2. wait untils finishez
3. see bas statistics -> panic!
  
Actual results:

[ggergely@vosztok ~]$ LC_ALL=hu_HU.UTF-8 dd if=/dev/zero of=/dev/null bs=4M
count=1024
1024+0 beolvasott rekord
1024+0 kiírt rekord
1 bájt (1 B) másolva, 0,24047 másodperc, 17,9 GB/mp
[ggergely@vosztok ~]$ 


Expected results:

[ggergely@vosztok ~]$ LC_ALL=C dd if=/dev/zero of=/dev/null bs=4M count=1024
1024+0 records in
1024+0 records out
4294967296 bytes (4.3 GB) copied, 0.242406 seconds, 17.7 GB/s
[ggergely@vosztok ~]$ 

(or the same in hungarian)


Additional info:

I use the hungrian locale. maybe a problem on other locales too.

Comment 1 Ondrej Vasik 2007-11-07 15:25:49 UTC
Sorry for delay, but I'm maintainer of that package only for short time.
with coreutils-5.97-12.6.fc6 on i386 architecture I got correct output:

$ ./dd if=/dev/zero of=/dev/null bs=4M count=1024
1024+0 beolvasott rekord
1024+0 kiírt rekord
4294967296 bytes (4,3 GB) copied, 0,187065 seconds, 23,0 GB/s

Works for me, is the error still occuring on your side? Maybe you can add some
specification of your system(architecture, something specific, did you tried
with later versions of coreutils(F7?))

Comment 2 Ondrej Vasik 2007-12-17 09:56:21 UTC
Closing as WORKSFORME , feel free to reopen it if the error still occurs on your
machine and you are still able to reproduce it.


Note You need to log in before you can comment on or make changes to this bug.