Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232429 - rpmbuild stores i386 libraries in incorrect directory under x86_64.
Summary: rpmbuild stores i386 libraries in incorrect directory under x86_64.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
: 231489 281401 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 14:34 UTC by thsacnc
Modified: 2008-01-15 14:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-15 14:09:17 UTC


Attachments (Terms of Use)

Description thsacnc 2007-03-15 14:34:38 UTC
Description of problem:
rpmbuild stores i386 libraries in incorrect directory under x86_64.fc6 environment. 

#rpmbuild --target=i386 -ba xxxxxx.spec
the .RPM package built should include i386 library files in /usr/lib, but in
/usr/lib64. Of course, rpm installs the files into the wrong directory: /usr/lib64.

Version-Release number of selected component (if applicable):
rpm-build-4.4.2-32.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Modify the spec file as follows;
"....
%build
echo %_target
echo %_lib
echo %_libdir
...."
2.run #rpmbuild --target=i386 -ba xxxxxx.spec

  
Actual results:
rpmbuild shows me;
"....
+ echo i386-linux
i386-linux
+ echo lib64
lib64
+ echo /usr/lib64
/usr/lib64
...."

Expected results:
"....
+ echo i386-linux
i386-linux
+ echo lib
lib
+ echo /usr/lib
/usr/lib
...."

Comment 1 Jeff Johnson 2007-03-15 16:22:52 UTC
This is fixed (by using arch from --target) in rpm-4.4.8. UPSTREAM

Meanwhile, change /etc/rpm/platform to have i386, not x86_64.

Comment 2 Red Hat Bugzilla 2007-08-21 05:32:33 UTC
User pnasrat@redhat.com's account has been closed

Comment 3 Panu Matilainen 2007-08-22 06:33:44 UTC
Reassigning to owner after bugzilla made a mess, sorry about the noise...

Comment 4 Panu Matilainen 2007-10-08 13:01:39 UTC
*** Bug 231489 has been marked as a duplicate of this bug. ***

Comment 5 Panu Matilainen 2007-10-24 11:51:11 UTC
*** Bug 281401 has been marked as a duplicate of this bug. ***

Comment 6 Panu Matilainen 2007-10-24 11:53:02 UTC
This is not going to get fixed for FC6, moving to devel to avoid "timeouting"
(and yes there are plans to fix this eventually)

Comment 7 Panu Matilainen 2008-01-15 14:09:17 UTC
This should work on rawhide as of rpm 4.4.2.2-13.


Note You need to log in before you can comment on or make changes to this bug.