Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232411 - yum-updatesd has a memory leak
Summary: yum-updatesd has a memory leak
Keywords:
Status: CLOSED DUPLICATE of bug 231743
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: noarch
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 11:18 UTC by Jan Gruenwald
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 22:04:45 UTC


Attachments (Terms of Use)

Description Jan Gruenwald 2007-03-15 11:18:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070223 Fedora/1.5.0.10-1.fc5 Firefox/1.5.0.10 pango-text

Description of problem:
If you watch the VmRSS field in /proc/<Pid of yum-updatesd>/status you will see that it grows over the time.



Version-Release number of selected component (if applicable):
yum-updatesd-3.0.3-1.fc6

How reproducible:
Always


Steps to Reproduce:
1. Start yum-updatesd 
2. Watch VmRSS in /proc/<Pid of yum-updatesd>/status
3. 

Actual Results:
The ResidentSetSize grows

Expected Results:
The ResidentSetSize should be constant !?

Additional info:
From one of my maschines:

[root@p15125001 ~]# rpm -q fedora-release
fedora-release-6-4
[root@p15125001 ~]$ free
             total       used       free     shared    buffers     cached
Mem:        246700     242760       3940          0       2104      10800
-/+ buffers/cache:     229856      16844
Swap:       557048     557048          0
[root@p15125001 ~]# /etc/init.d/yum-updatesd restart
Stopping yum-updatesd:                                     [  OK  ]
Starting yum-updatesd:                                     [  OK  ]
[root@p15125001 ~]# free
             total       used       free     shared    buffers     cached
Mem:        246700     162764      83936          0       4108      35284
-/+ buffers/cache:     123372     123328
Swap:       557048      23924     533124


After that I did a 5min check on /proc/<Pid of yum-updatesd>/status on VmRSS.
This is the result:

2007-03-13_14:35:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_14:40:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_14:45:02   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_14:50:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_14:55:02   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_15:00:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_15:05:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_15:10:01   PS: yum-updatesd   PID: 9260   RSS: 9652 kb
2007-03-13_15:15:03   PS: yum-updatesd   PID: 9260   RSS: 13968 kb
2007-03-13_15:20:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:25:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:30:02   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:35:02   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:40:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:45:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:50:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_15:55:02   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_16:00:02   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_16:05:02   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_16:10:01   PS: yum-updatesd   PID: 9260   RSS: 40524 kb
2007-03-13_16:15:02   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:20:02   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:25:01   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:30:01   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:35:01   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:40:02   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:45:05   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:50:01   PS: yum-updatesd   PID: 9260   RSS: 47380 kb
2007-03-13_16:55:02   PS: yum-updatesd   PID: 9260   RSS: 47380 kb

Comment 1 Jeremy Katz 2007-03-19 22:04:45 UTC

*** This bug has been marked as a duplicate of 231743 ***


Note You need to log in before you can comment on or make changes to this bug.