Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232404 - 'error reading non-root config file' when no user configfile is available
Summary: 'error reading non-root config file' when no user configfile is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd
Version: 3.8
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Maros Barabas
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-15 09:15 UTC by Martin (calim)
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version: RHBA-2007-0425
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-11 18:44:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0425 normal SHIPPED_LIVE vsftpd bug fix update 2007-06-07 19:25:00 UTC

Description Martin (calim) 2007-03-15 09:15:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):

vsftpd-1.2.1-3E.6
This bug seems to exists on centos 4.3 too.
http://bugs.centos.org/view.php?id=1393

How reproducible:

If i set user_config_dir in vsftpd.conf each user has to have a config file
othervise the connection get's terminated.
This behaviour is definitly wrong and the error message is misleading.

The reason for this behaviour is a bug in file 'twoprocess.c' around line 422

see additional information.


Additional info:

/* Security - ignore unless owned by root */
if (!vsf_sysutil_retval_is_error(retval) &&
    vsf_sysutil_statbuf_get_uid(p_statbuf) == VSFTP_ROOT_UID)
{
  vsf_parseconf_load_file(str_getbuf(&filename_str), 1);
} else {
  die('error reading non-root config file');
}

THE BUG:
The 'else' part (which throws the error) is not only entered if the config file
is not owned by root, it is also entered if the user config file does not exist.

Comment 1 Martin (calim) 2007-03-19 15:49:33 UTC
Hi there !

any news ?

Comment 3 RHEL Product and Program Management 2007-03-21 07:04:33 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 4 Martin (calim) 2007-03-21 15:27:33 UTC
Notice: Just to remind the bug exists in the centos 4 package too. (see the
centos bug report above).

Comment 5 Maros Barabas 2007-03-28 11:27:10 UTC
Hi,

     please try vsftpd-1.2.1-3E.9.

Comment 6 Martin (calim) 2007-03-28 13:30:21 UTC
from where do I get the package ?

Comment 7 Martin (calim) 2007-03-29 13:29:09 UTC
i can test this package if you give me a download link :) I would be happy to
know what changes has been made too ^^

Comment 8 Maros Barabas 2007-04-02 07:41:53 UTC
Hi,
  sorry for delay, here is the link:
    http://people.redhat.com/rbiba/maros/vsftpd-1.2.1-3E.9.src.rpm

Comment 9 Martin (calim) 2007-04-02 08:44:21 UTC
Thank you : Seems ok for the moment. I suggest to wait 24h for eventual side effect.

Comment 10 Martin (calim) 2007-04-02 08:50:01 UTC
Ah, as the problem also exists on centos 4, do you plan to build a RPM for this
release too ?

Comment 11 Maros Barabas 2007-04-02 10:56:33 UTC
Red Hat doesn't support CentOS at all. If you are asking about this bug on rhel
4 I hope that soon.

Comment 12 Martin (calim) 2007-04-02 11:19:32 UTC
Yes sorry, I spoke about rhel4. If you need I can open the same bug report for
rhel 4 (to keep in mind).

Comment 18 Red Hat Bugzilla 2007-06-11 18:44:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0425.html


Comment 19 Martin (calim) 2007-06-13 09:16:42 UTC
Thank you. Is it fixed for RHEL4 too ?


Note You need to log in before you can comment on or make changes to this bug.