Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232392 - qt4: qmake does not set CC, CXX, etc, mkspecs/common awol?
Summary: qt4: qmake does not set CC, CXX, etc, mkspecs/common awol?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4
Version: rawhide
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 229676
TreeView+ depends on / blocked
 
Reported: 2007-03-15 06:20 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 14:36:37 UTC


Attachments (Terms of Use)
Makefile generated by qmake 4.4.3-1 from qgle.pro (deleted)
2007-03-15 06:20 UTC, Mamoru TASAKA
no flags Details
qgle.pro and qgle.qrc (deleted)
2007-03-15 06:25 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2007-03-15 06:20:12 UTC
Description of problem:
Currently I am reviewing gle (bug 229676), which fails
to be rebuilt by mockbuild on FC-devel i386.
However, with qt4-devel-4.2.2-7.fc7, rpmbuild ends sucessfully.

Makefile created by qmake from qgle.pro doesn't contain
CC, CXX variables

Version-Release number of selected component (if applicable):
qt4-devel-4.2.3-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. Try to rebuild gle-4.0.12a-1.fc6 on bug 229676
2.
3.
  
Actual results:
With qt-devel 4.2.3-1:
---------------------------------------
make[1]: Entering directory `/home/tasaka1/rpmbuild/BUILD/gle4/src/gui'
/usr/lib/qt4/bin/qmake
make
make[2]: Entering directory `/home/tasaka1/rpmbuild/BUILD/gle4/src/gui'
c -DQT_NO_DEBUG_OUTPUT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
-I/usr/lib/qt4/mkspecs/linux-g++ 
-I. -I/QtCore -I/QtNetwork -I/QtGui -I. -Imoc -I. -o objects/qgle_statics.o
qgle_statics.cpp
make[2]: c: Command not found
make[2]: [objects/qgle_statics.o] Error 127 (ignored)
c -DQT_NO_DEBUG_OUTPUT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
-I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/QtCore -I/QtNetwork -I/QtGui -I. -Imoc
-I. -o objects/main.o main.cpp
make[2]: c: Command not found
make[2]: [objects/main.o] Error 127 (ignored)


Expected results:
With qt-devel 4.2.2-7:
-----------------------------------------------
make[1]: Entering directory `/home/tasaka1/rpmbuild/BUILD/gle4/src/gui'
/usr/lib/qt4/bin/qmake
make
make[2]: Entering directory `/home/tasaka1/rpmbuild/BUILD/gle4/src/gui'
g++ -c -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -D_REENTRANT -Wall -W  -DQT_NO_DEBUG_OUTPUT
-DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB
-I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/QtCore
-I/usr/include/QtCore -I/usr/include/QtNetwork -I/usr/include/QtNetwork
-I/usr/include/QtGui -I/usr/include/QtGui -I/usr/include -I. -Imoc -I. -o
objects/qgle_statics.o qgle_statics.cpp

Comment 1 Mamoru TASAKA 2007-03-15 06:20:12 UTC
Created attachment 150110 [details]
Makefile generated by qmake 4.4.3-1 from qgle.pro

Comment 2 Mamoru TASAKA 2007-03-15 06:25:33 UTC
Created attachment 150111 [details]
qgle.pro and qgle.qrc

Comment 3 Rex Dieter 2007-03-15 11:58:24 UTC
Thanks for the report.

Looks like breakage caused by recent multilib fixes, and that we need a symlink
%_libdir/qt4/mkspecs/common -> %_datadir/qt4/mkspecs/common

I'll test this a bit more, and push out a fix asap.




Comment 4 Rex Dieter 2007-03-15 14:36:37 UTC
* Thu Mar 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2.3-2
- fix mkspecs/common availability (#232392)

Comment 5 Mamoru TASAKA 2007-03-15 15:16:14 UTC
4.2.3-3 works for me.
Thank you!


Note You need to log in before you can comment on or make changes to this bug.