Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232373 - ctrl-arrow keys no longer work.
Summary: ctrl-arrow keys no longer work.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-03-15 01:18 UTC by Dave Jones
Modified: 2015-01-04 22:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-03 05:29:44 UTC


Attachments (Terms of Use)
Single-shift to G3 should not have modifier keys (deleted)
2007-05-07 22:54 UTC, James Bowes
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 425462 None None None Never

Description Dave Jones 2007-03-15 01:18:35 UTC
This is probably somewhere lower in the system than vim, but I'm not sure where
to start looking, so I'm hoping I get lucky with ncurses.

In vim, ctrl-right arrow no longer operates as 'skip over the next word', but
now inserts 1;5c

The other arrow keys do the same thing for different codes.

Comment 1 Miroslav Lichvar 2007-03-15 16:29:25 UTC
In which terminal is this happening, in gnome-terminal?

Comment 2 Miroslav Lichvar 2007-03-19 17:10:26 UTC
gnome-terminal generates escape sequences that vim doesn't recognize, ^[O1;5D
^[O1;5C are generated for ctrl-left ctrl-right while in FC6 gnome-terminal it is
^[O5D ^[O5C.


Comment 3 Dave Jones 2007-04-26 18:37:06 UTC
The wrong characters are also being sent when you use a terminal to ssh.
locally, ctrl-left skips over previous words in bash. but if you ssh somewhere
and try to do the same thing, you'll get ;5D printed out

This bug is *really* irritating, and should get fixed for F7 GA.


Comment 4 Will Woods 2007-04-26 21:35:13 UTC
Yeah, this is a gnome-terminal bug. Ubuntu users have noted similar problems
because gnome-terminal has changed what sequences it outputs for various key
combinations.

See the GNOME bug here: http://bugzilla.gnome.org/show_bug.cgi?id=425462

Comment 5 James Bowes 2007-05-07 22:54:27 UTC
Created attachment 154303 [details]
Single-shift to G3 should not have modifier keys

Here's a patch that seems to work for me, based on the change to xterm
mentioned in the Gnome bug.

Comment 6 Will Woods 2007-05-08 14:21:57 UTC
Based on the comments in the original gnome bug:
http://bugzilla.gnome.org/show_bug.cgi?id=337252

which was linked from the Ubuntu bug I mentioned:
https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/96676

this looks to be more of a vte bug than gnome-terminal. So I assume this is a
vte patch? I'll apply it and see how it works.

Comment 7 James Bowes 2007-05-08 14:28:25 UTC
(In reply to comment #6)
> this looks to be more of a vte bug than gnome-terminal. So I assume this is a
> vte patch? I'll apply it and see how it works.

Yeah it is. I forgot to mention that part.


Comment 8 Will Woods 2007-05-08 14:56:44 UTC
Having patched vte-0.16.3-2, ctrl-arrow works properly in vi/vim (yay!).

However, it still doesn't work right in irssi (boo!).

Also, shift-arrow causes bash to emit partial escape sequences, so we might need
to add some inputrc magic to handle the new stuff that vte is emitting.. but
that might be another bug.

Comment 9 James Bowes 2007-05-08 16:54:05 UTC
(In reply to comment #8)
> Having patched vte-0.16.3-2, ctrl-arrow works properly in vi/vim (yay!).
> 
> However, it still doesn't work right in irssi (boo!).
> 
> Also, shift-arrow causes bash to emit partial escape sequences, so we might need
> to add some inputrc magic to handle the new stuff that vte is emitting.. but
> that might be another bug.

I'm not sure about irssi, but for bash i figure the problem is that the code I
wrote doesn't care if your in application mode or not, nor does it care if the
key pressed was a cursor key or not.



Comment 10 Behdad Esfahbod 2007-05-08 18:35:20 UTC
Please discuss upstream or your comments will be ignored.

Comment 11 Will Woods 2007-05-11 04:42:43 UTC
The problem with irssi turns out to be an irssi bug, fixed upstream. With the
two current patches in the upstream bugzilla, ctrl-arrow works as expected in
(newer) irssi and vim, but not vim in a screen session. Alas.

Still, as long as vte behavior matches xterm's, anything else is an application
bug rather than a terminal bug.

Comment 12 Will Woods 2007-05-11 17:14:40 UTC
This bug, while completely annoying, doesn't keep anyone from installing or
using their system. Moving to FC7Target.

Comment 13 Dave Jones 2007-05-15 17:27:59 UTC
It's irritating enough to have made me downgrade one machine back to FC6 though.
This really should get fixed for GA imo, or we'll have a lot of dupes of this
after release.

Comment 14 Behdad Esfahbod 2007-05-23 00:46:15 UTC
The upstream bug is fixed now.
Can someone check vte trunk and see if this is indeed fixed?

Comment 15 Matthias Clasen 2007-05-25 13:27:23 UTC
Is it ? The bugs seem to be still open. 

Comment 16 Behdad Esfahbod 2007-05-25 20:47:58 UTC
A similar bug was fixed.  GNOME bug 440475.

Comment 17 Behdad Esfahbod 2007-05-25 20:48:26 UTC
Sorry, meant GNOME Bug 375112 – ctrl-key combinations yielding just key

Comment 18 James Bowes 2007-06-02 16:36:43 UTC
The bug is still there in vte 0.16.4

Comment 19 Dave Jones 2007-07-12 20:47:23 UTC
also still there in vte-0.16.6-1.fc7

Comment 20 Dave Jones 2007-09-21 20:41:58 UTC
and vte-0.16.8-1.fc7

It does seem to be fixed in rawhide however.  Any chance of a backport?

Comment 21 Behdad Esfahbod 2007-09-22 22:53:00 UTC
(In reply to comment #20)
> and vte-0.16.8-1.fc7
> 
> It does seem to be fixed in rawhide however.  Any chance of a backport?

The difference between 0.16.8 and 0.16.9 that is in rawhide is really small.  I
can't imagine how it could make the difference.  I'm guessing that tother
software chaned in between  fixing the issue.  Anyway, pushing 0.16.9 in f7
Updates Testing, please test and let me know if it works.

Comment 22 Dave Jones 2007-10-03 18:24:39 UTC
You were right, upgrading vte to 0.16.9 in F7 doesn't solve the issue.


Comment 23 Dave Jones 2007-11-17 01:48:32 UTC
So, this bug has changed slightly.  Initially, ctrl-arrow worked in bash, but
not in vim.   Now in F8 the opposite is true.

in bash..
ctrl-left prints ;5D
shift-left prints ;2D
alt-left prints ;3D


Comment 24 Bastien Nocera 2007-11-17 02:14:38 UTC
(In reply to comment #23)
> So, this bug has changed slightly.  Initially, ctrl-arrow worked in bash, but
> not in vim.   Now in F8 the opposite is true.
> 
> in bash..
> ctrl-left prints ;5D
> shift-left prints ;2D
> alt-left prints ;3D

I'd check my bash settings, because it works fine here.

Comment 25 Behdad Esfahbod 2007-12-17 18:18:12 UTC
Yep.  F8 works fine here.  You've got TERM=xterm, right?

Comment 26 Dave Jones 2008-01-17 19:15:34 UTC
With no .bashrc (ie, just the F8 defaults). I still get the broken behaviour.

bash-3.2$ export | grep TERM
declare -x COLORTERM="gnome-terminal"
declare -x TERM="xterm"


Comment 27 Behdad Esfahbod 2008-01-17 19:43:04 UTC
Donno.  What about a new account?


Comment 28 Matthias Clasen 2008-03-17 18:48:30 UTC
I just tried in a freshly installed F9beta, and it works fine.

Comment 29 Matthias Clasen 2008-03-28 19:51:56 UTC
Dave, problem solved for you ?

Comment 30 Matthias Clasen 2008-04-03 05:29:44 UTC
Declaring this fixed for now. 
If you got anything new, just reopen.


Note You need to log in before you can comment on or make changes to this bug.