Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232370 - Loading tifm_core should automatically load tifm_sd
Summary: Loading tifm_core should automatically load tifm_sd
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Jon Masters
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2007-03-15 01:13 UTC by Michel Alexandre Salim
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-08-27 06:03:54 UTC

Attachments (Terms of Use)

Description Michel Alexandre Salim 2007-03-15 01:13:33 UTC
Description of problem:
I have a Texas Instrument card reader (tifm_7xx1); currently it is detected
out-of-the-box, and some kernel modules (tifm_core and tifm_7xx1) loaded;
however, the third module, tifm_sd, is not. The kernel would thus detect card
insertions and removals, but would not create the device node needed for mounting

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot computer
2. Insert SD card
3. dmesg
Actual results:
Device insertion is reported, but no device is created in /dev

Expected results:
Device node should be created in /dev

Additional info:

Comment 1 Aurelien Bompard 2007-03-16 15:43:43 UTC
I confirm this, here is the relevant output of lspci:
02:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
02:06.3 Class 0805: Texas Instruments PCIxx12 SDA Standard Compliant SD Host


Comment 2 Daniel Qarras 2007-06-27 18:28:33 UTC
This is the same or least related to

which just got solved with a minor change to udev.

Comment 3 Jon Masters 2007-08-20 06:11:40 UTC
Is this still an issue? If so, let's get udev changed again.


Comment 4 Mikkel L. Ellertson 2007-08-23 17:48:37 UTC
What I did is create a pair of udev rules to load and unload the tifm_sd rules
when a card is inserted or removed. I believe this is needed because there are
seperate modules that need to be loaded to match the type of card being
inserted. Because I only have SD cards, I can not check if my rules do a proper
check, but it should be possible to add udev rules that load/unload the correct
module with better matching then I have...

# SD card in tifm socket control.
BUS=="tifm", ACTION=="add", ID=="tifm_sd0:1", RUN+="modprobe tifm_sd"
BUS=="tifm", ACTION=="remove", ID=="tifm_sd0:1", RUN+="modprobe -r tifm_sd"

I do have one problem though - it is not getting automounted. But I think this
is a HAL problem...

[mikkel@toshiba ~]$ gnome-mount -v -b -d /dev/mmcblk0p1 -m music
gnome-mount 0.5
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.

** (gnome-mount:5585): WARNING **: Given device '/dev/mmcblk0p1' is not a volume
or a drive.
[mikkel@toshiba ~]$ ls -l /dev/mmc*
brw-r----- 1 root disk 179, 0 Aug 23 12:04 /dev/mmcblk0
brw-r----- 1 root disk 179, 1 Aug 23 12:04 /dev/mmcblk0p1

Comment 5 Daniel Qarras 2007-08-25 14:03:11 UTC
I suggest you to test with udev-113-11.fc7, it fixed Bug 217070 for me and my SD
card reader works now perfectly with F7!

Note You need to log in before you can comment on or make changes to this bug.