Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232341 - If system does not check in, applicable errata updates are not scheduled
Summary: If system does not check in, applicable errata updates are not scheduled
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 20:31 UTC by Máirín Duffy
Modified: 2007-10-24 01:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-14 15:16:01 UTC


Attachments (Terms of Use)

Description Máirín Duffy 2007-03-14 20:31:28 UTC
post-rhn 500:

Systems that check in get auto errata updates scheduled, but if the system
doesn't check in after the errata is released, the errata update doesn't get
scheduled (even though if you run up2date -l the system shows it needs the update.)

(where 'check in' == rhn_check or up2date -p, somehow up2date -l doesn't seem to
trigger the update getting scheduled)

Comment 1 daryl herzmann 2007-03-14 20:35:58 UTC
Thanks for posting the bug.  It appears that at some point, the errata is sort
of scheduled for the machine since they show up as "Pending Events".  But the
association that the errata applies to the machine is not made on the web GUI. 
I think that is another bz entry.

Comment 3 Máirín Duffy 2007-03-14 20:43:41 UTC
re comment 1, the seamonkey errata for the sid in question is not pending as of
1.5 days after the errata was released

this bug may be related to: bug 226897 (closed, rhn500), bug 232235, bug 232061

Comment 4 daryl herzmann 2007-03-14 20:51:02 UTC
thanks.  That is correct.  

As an aside, IMHO, the requirement that a system check into RHN in order for the
Web GUI to be updated seems to cause a good amount of confusion.  If the web GUI
was updated when the errata is released, perhaps it would be less confusing. 
For example. 

1. Errata is released.
2. I go to RHN GUI and see it applies to 40 of my systems, 10 have picked it up
already, 30 have it scheduled.
3. I go along my happy way.

Current, step #2 is not possible with RHN.  I would only see the number of
machines that are currently checking in and have seen the errata.  step #3 is
not possible either, since I am bitter in my old age! :)

hopefully my comment is on-topic for this bug.  thanks!


Comment 6 daryl herzmann 2007-03-15 02:09:29 UTC
Good evening.

Strangely enough,  the wireshark errata now shows up in the "relevent errata"
for this system in question.  seamonkey should be there, but isn't.  Will be
curious to see what the next errata does :)

Comment 7 Máirín Duffy 2007-03-15 15:01:00 UTC
Just to confirm, the wireshark errata that went out a day ago is not yet
scheduled for the system 'amelia' (sid in comment #5), right?

Comment 8 daryl herzmann 2007-03-15 15:10:12 UTC
wireshark is scheduled
seamonkey is not 

thanks!

Comment 9 Kevin A. Smith 2007-03-15 19:28:34 UTC
This is very strange. I've been going thru all the queries used in the errata
processing and scheduling code. I can't find any queries which even reference
the rhnServerInfo table, which is where we keep track of when servers check in.

I'm going to take a look at how we determine which servers get autoupdates and
see if there's any issues there. I was in that code for the last release
(RHN500) and so I think its pretty solid, but I'll take another look.

Comment 12 Mike Orazi 2007-05-14 15:16:01 UTC

*** This bug has been marked as a duplicate of 237590 ***

Comment 13 daryl herzmann 2007-05-14 15:22:10 UTC
Thanks for closing this bug in favour of a bug we can not see :(

Comment 14 Máirín Duffy 2007-05-14 15:35:47 UTC
Hi Daryl, sorry about that, that was not our intention. I've opened up bug
237590 and added you and John to it. Thanks for speaking up!


Note You need to log in before you can comment on or make changes to this bug.