Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232340 - INFO: inconsistent lock state 2.6.20-1.2986.fc7 serial8250_backup_timeout
Summary: INFO: inconsistent lock state 2.6.20-1.2986.fc7 serial8250_backup_timeout
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
: 237515 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 20:22 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-17 20:37:41 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2007-03-14 20:22:27 UTC
On a Dell PowerEdge 2650:

<4>[ INFO: inconsistent lock state ]
<4>2.6.20-1.2986.fc7 #1
<4>---------------------------------
<4>inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
<4>swapper/0 [HC1[1]:SC0[0]:HE0:SE1] takes:
<4> (&port_lock_key){++..}, at: [<c05580ca>] serial8250_interrupt+0x4a/0xe0
<4>{hardirq-on-W} state was registered at:
<4>  [<c0440085>] __lock_acquire+0x448/0xba9
<4>  [<c0440bd8>] lock_acquire+0x56/0x6f
<4>  [<c060edf1>] _spin_lock+0x2b/0x38
<4>  [<c0557a6f>] serial8250_backup_timeout+0x6d/0xe8
<4>  [<c042c91c>] run_timer_softirq+0x121/0x189
<4>  [<c0429e13>] __do_softirq+0x6f/0xe2
<4>  [<c0407a74>] do_softirq+0x61/0xd0
<4>  [<ffffffff>] 0xffffffff
<4>irq event stamp: 274386
<4>hardirqs last  enabled at (274385): [<c0403de2>] default_idle+0x3e/0x59
<4>hardirqs last disabled at (274386): [<c0406064>] common_interrupt+0x24/0x40
<4>softirqs last  enabled at (274376): [<c0429e80>] __do_softirq+0xdc/0xe2
<4>softirqs last disabled at (274359): [<c0407a74>] do_softirq+0x61/0xd0
<4>
<4>other info that might help us debug this:
<4>1 lock held by swapper/0:
<4> #0:  (&irq_lists[i].lock){+...}, at: [<c0558095>] serial8250_interrupt+0x15/0xe0
<4>
<4>stack backtrace:
<4> [<c0406842>] show_trace_log_lvl+0x1a/0x2f
<4> [<c0406e01>] show_trace+0x12/0x14
<4> [<c0406e85>] dump_stack+0x16/0x18
<4> [<c043eb7b>] print_usage_bug+0x141/0x14b
<4> [<c043f26a>] mark_lock+0xa2/0x419
<4> [<c043fff6>] __lock_acquire+0x3b9/0xba9
<4> [<c0440bd8>] lock_acquire+0x56/0x6f
<4> [<c060edf1>] _spin_lock+0x2b/0x38
<4> [<c05580ca>] serial8250_interrupt+0x4a/0xe0
<4> [<c04567aa>] handle_IRQ_event+0x1a/0x46
<4> [<c045789a>] handle_fasteoi_irq+0x7d/0xb6
<4> [<c0407b94>] do_IRQ+0xb1/0xd9

Comment 1 Dave Jones 2007-04-23 16:30:14 UTC
Are you still seeing this with the current builds ?

Comment 2 Orion Poplawski 2007-04-23 16:38:14 UTC
*** Bug 237515 has been marked as a duplicate of this bug. ***

Comment 3 Orion Poplawski 2007-04-23 16:39:24 UTC
Yup, just filed a duplicate by accident.

<4>=================================
<4>[ INFO: inconsistent lock state ]
<4>2.6.20-1.3094.fc7 #1
<4>---------------------------------
<4>inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
<4>swapper/0 [HC1[1]:SC0[0]:HE0:SE1] takes:
<4> (&port_lock_key){++..}, at: [<c0558f96>] serial8250_interrupt+0x4a/0xe0
<4>{hardirq-on-W} state was registered at:
<4>  [<c044021d>] __lock_acquire+0x448/0xba9
<4>  [<c0440d70>] lock_acquire+0x56/0x6f
<4>  [<c060ffd1>] _spin_lock+0x2b/0x38
<4>  [<c055893b>] serial8250_backup_timeout+0x6d/0xe8
<4>  [<c042c972>] run_timer_softirq+0x121/0x189
<4>  [<c0429dfb>] __do_softirq+0x6f/0xe2
<4>  [<c0407a64>] do_softirq+0x61/0xd0
<4>  [<ffffffff>] 0xffffffff
<4>irq event stamp: 332718
<4>hardirqs last  enabled at (332717): [<c0403dde>] default_idle+0x3e/0x59
<4>hardirqs last disabled at (332718): [<c0406054>] common_interrupt+0x24/0x40
<4>softirqs last  enabled at (332708): [<c0429e68>] __do_softirq+0xdc/0xe2
<4>softirqs last disabled at (332691): [<c0407a64>] do_softirq+0x61/0xd0
<4>
<4>other info that might help us debug this:
<4>1 lock held by swapper/0:
<4> #0:  (&irq_lists[i].lock){+...}, at: [<c0558f61>] serial8250_interrupt+0x15/0xe0
<4>
<4>stack backtrace:
<4> [<c0406832>] show_trace_log_lvl+0x1a/0x2f
<4> [<c0406df1>] show_trace+0x12/0x14
<4> [<c0406e75>] dump_stack+0x16/0x18
<4> [<c043ed13>] print_usage_bug+0x141/0x14b
<4> [<c043f402>] mark_lock+0xa2/0x419
<4> [<c044018e>] __lock_acquire+0x3b9/0xba9
<4> [<c0440d70>] lock_acquire+0x56/0x6f
<4> [<c060ffd1>] _spin_lock+0x2b/0x38
<4> [<c0558f96>] serial8250_interrupt+0x4a/0xe0
<4> [<c045699a>] handle_IRQ_event+0x1a/0x46
<4> [<c0457a8a>] handle_fasteoi_irq+0x7d/0xb6
<4> [<c0407b84>] do_IRQ+0xb1/0xd9
<4> =======================


Comment 4 Orion Poplawski 2007-10-17 20:37:41 UTC
No longer testing on this hardware, not seeing anywhere else.


Note You need to log in before you can comment on or make changes to this bug.