Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232334 - releasever macro is not reporting proper version
Summary: releasever macro is not reporting proper version
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bret McMillan
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 19:58 UTC by Chris Stankaitis
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-22 22:10:20 UTC


Attachments (Terms of Use)

Description Chris Stankaitis 2007-03-14 19:58:01 UTC
Description of problem:

Installed a custom yum repository.  My YUM line in rhn/sources is

yum dw-noarch https://yum.URL.net/redhat/$releasever/noarch
yum dw-$basearch https://yum.URL.net/redhat/$releasever/$basearch

My RHEL 4 boxes (U3 & U4) are reporting their releasever as "3" and not "4"

In /usr/share/rhn/up2date_client/sourcesConfig.py a search for releasever turns up

     releasever = up2dateUtils.getVersion()

        #FIXME:
        releasever = "3"

It would apear you guys have elected to hard code the release version, and this
has not gotten fixed.

Version-Release number of selected component (if applicable):

up2date-4.4.69-25.i386

Actual results:

Fetching Obsoletes list for channel: dw-noarch...

Fetching obsoletes list for https://yum.URL.net/redhat/3/noarch...
#############
Fetching Obsoletes list for channel: dw-i386...

Fetching obsoletes list for https://yum.URL.net/redhat/3/i386...


Expected results:

https://yum.URL.net/redhat/4/i386...

Comment 1 Chris Stankaitis 2007-03-14 19:59:47 UTC
Can I change that hard-coded releasever in the sourcesConfig.py to "4" without
fracking everything else up?... or is this fix more complicated then that.

Comment 2 Ijaaz A. Ullah 2007-03-14 20:02:12 UTC
google shows me that this was opened at one point in time under:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229847

but it doesn't seem to be accessible anymore?

Comment 3 Red Hat Bugzilla 2007-04-12 02:15:07 UTC
User bnackash@redhat.com's account has been closed

Comment 4 Pradeep Kilambi 2007-05-22 22:10:20 UTC

*** This bug has been marked as a duplicate of 229847 ***


Note You need to log in before you can comment on or make changes to this bug.