Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232312 - rhino fails to run
Summary: rhino fails to run
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhino
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wringe
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 19:46 UTC by Anthony Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 17:55:20 UTC


Attachments (Terms of Use)

Description Anthony Green 2007-03-14 19:46:44 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Anthony Green 2007-03-14 19:47:49 UTC
(In reply to comment #0)
> Description of problem:

Oops.  I hit "submit" a little too early!

Here's what I'm seeing in rawhide today:
$ rhino
/usr/bin/build-classpath: error: Could not find xmlbeans/xbean Java extension
for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Exception in thread "main" java.lang.NoClassDefFoundError:
org.mozilla.javascript.tools.shell.Main
   at gnu.java.lang.MainThread.run(libgcj.so.8rh)
Caused by: java.lang.ClassNotFoundException:
org.mozilla.javascript.tools.shell.Main not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/rhino.jar,file:./],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.8rh)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.8rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
   at gnu.java.lang.MainThread.run(libgcj.so.8rh)


Comment 2 Matt Wringe 2007-03-15 17:55:20 UTC
That script should not have been included, it has now been removed in rawhide.
The script was meant to run a debugging tool which we cannot include due to
licensing issues.


Note You need to log in before you can comment on or make changes to this bug.