Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232305 - audio open error - ??????? GStreamer ????????
Summary: audio open error - ??????? GStreamer ????????
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 19:39 UTC by benjamin wu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-10 09:17:34 UTC


Attachments (Terms of Use)
System Config Soundcard Log (deleted)
2007-03-14 19:39 UTC, benjamin wu
no flags Details

Description benjamin wu 2007-03-14 19:39:14 UTC
Description of problem:
音量控制無法找到任何可控制的元件或裝置。即是代表沒有安裝正確的 GStreamer 外掛程
式,或是沒有設置好的音效卡。
------- System Config Soundcard Log --------
四  3月 15 03:18:36 CST 2007

ALSA lib pcm_hw.c:1357:(_snd_pcm_hw_open) Invalid value for card
aplay: main:550: audio open error: 沒有此一裝置
amixer: Mixer attach default error: No such file or directory


Version-Release number of selected component (if applicable):
 2.6.19-1.2911.6.5.fc6 #1 SMP

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 benjamin wu 2007-03-14 19:39:14 UTC
Created attachment 150084 [details]
System Config Soundcard Log

Comment 2 Bastien Nocera 2007-04-01 14:09:06 UTC
system-config-soundcard doesn't use GStreamer, reassigning.

Comment 3 Martin Stransky 2007-04-02 09:17:17 UTC
Your system looks broken, see dmesg. Looks like a problem with kernel.

The error message from sound subsystem is here:

Intel ICH: probe of 0000:00:1f.5 failed with error -16

but I don't think it's the main problem. I suggest to fix the kernel first and
then sort out the sound problem.


Comment 4 Martin Stransky 2007-04-02 09:18:24 UTC
See all those messages:

--------------------------------------------------------

PCI: Enabling device 0000:00:1f.5 (0005 -> 0007)
PCI: No IRQ known for interrupt pin B of device 0000:00:1f.5. Please try using
pci=biosirq.
IRQ handler type mismatch for IRQ 0
current handler: timer
 [<c040566b>] dump_trace+0x69/0x1b6
 [<c04057d0>] show_trace_log_lvl+0x18/0x2c
 [<c0405dc6>] show_trace+0xf/0x11
 [<c0405ec3>] dump_stack+0x15/0x17
 [<c044e9f9>] setup_irq+0x179/0x199
 [<c044ea95>] request_irq+0x7c/0x98
 [<e02a1aeb>] snd_intel8x0_probe+0x457/0xf7c [snd_intel8x0]
 [<c04f6b6d>] pci_device_probe+0x36/0x57
 [<c05561f4>] really_probe+0x39/0xda
 [<c055642b>] __driver_attach+0x73/0xab
 [<c0555904>] bus_for_each_dev+0x39/0x5b
 [<c0556117>] driver_attach+0x16/0x18
 [<c0555bd5>] bus_add_driver+0x61/0x165
 [<c04f6cc5>] __pci_register_driver+0x6f/0x89
 [<c043eef8>] sys_init_module+0x17fc/0x19a7
 [<c0404057>] syscall_call+0x7/0xb
 [<00565402>] 0x565402
 =======================
unable to grab IRQ 0
Intel ICH: probe of 0000:00:1f.5 failed with error -16
eth1: RealTek RTL8139 at 0xe0032c00, 00:0e:a6:33:be:fe, IRQ 5
eth1:  Identified 8139 chip type 'RTL-8101'
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00e0180003141ca6]
PCI: No IRQ known for interrupt pin B of device 0000:00:1f.6. Please try using
pci=biosirq.
IRQ handler type mismatch for IRQ 0
current handler: timer
 [<c040566b>] dump_trace+0x69/0x1b6
 [<c04057d0>] show_trace_log_lvl+0x18/0x2c
 [<c0405dc6>] show_trace+0xf/0x11
 [<c0405ec3>] dump_stack+0x15/0x17
 [<c044e9f9>] setup_irq+0x179/0x199
 [<c044ea95>] request_irq+0x7c/0x98
 [<e02e9de2>] snd_intel8x0m_probe+0x239/0x6bc [snd_intel8x0m]
 [<c04f6b6d>] pci_device_probe+0x36/0x57
 [<c05561f4>] really_probe+0x39/0xda
 [<c055642b>] __driver_attach+0x73/0xab
 [<c0555904>] bus_for_each_dev+0x39/0x5b
 [<c0556117>] driver_attach+0x16/0x18
 [<c0555bd5>] bus_add_driver+0x61/0x165
 [<c04f6cc5>] __pci_register_driver+0x6f/0x89
 [<c043eef8>] sys_init_module+0x17fc/0x19a7
 [<c0404057>] syscall_call+0x7/0xb
 [<00b04402>] 0xb04402
 =======================
unable to grab IRQ 0
Intel ICH Modem: probe of 0000:00:1f.6 failed with error -16

--------------------------------------------------------


Note You need to log in before you can comment on or make changes to this bug.