Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232285 - Can't open saved ks.cfg
Summary: Can't open saved ks.cfg
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 18:38 UTC by Steve Magoun
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 14:07:04 UTC


Attachments (Terms of Use)

Description Steve Magoun 2007-03-14 18:38:01 UTC
Description of problem:
system-config-kickstart can't open files it creates if the file contains the @base group in the %packages 
section.


Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.3-1.fc7


How reproducible:
Always

Steps to Reproduce:
1. Launch system-config-kickstart
2. Select "Perform new installation" from Installation Method (required because of bug 232282)
3. Under Package Selection, choose only Base System->Base
4. Save the file
5. Open the saved file
  
Actual results:
I get a dialog box with error information:

Component: system-config-kickstart
Summary: TBf4165d19 packages.py:234:<lambda>:AttributeError: Group instance has no attribute 
'__getitem__'

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 308, in on_activate_open
    self.applyKickstart()
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 340, in applyKickstart
    self.packages_class.applyKickstart()
  File "/usr/share/system-config-kickstart/packages.py", line 234, in applyKickstart
    selectedGroups = map (lambda grp: grp[1], self.ks.packages.groupList)
  File "/usr/share/system-config-kickstart/packages.py", line 234, in <lambda>
    selectedGroups = map (lambda grp: grp[1], self.ks.packages.groupList)
AttributeError: Group instance has no attribute '__getitem__'

Local variables in innermost frame:
grp: @base



Expected results:
Kickstart file is loaded without errors


Additional info:

Comment 1 Chris Lumens 2007-03-15 14:07:04 UTC
Looks like more fallout from the switch to the new pykickstart.  This will be
fixed in the next build.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.