Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232276 - Kernel hangs working with crypted loop device
Summary: Kernel hangs working with crypted loop device
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 17:27 UTC by Artem S. Tashkinov
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 22:49:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
A script in use (deleted)
2007-03-14 17:27 UTC, Artem S. Tashkinov
no flags Details

Description Artem S. Tashkinov 2007-03-14 17:27:59 UTC
Description of problem: kernel hangs when writing multiple files simultaneously
on a filesystem which remains on a encrypted loop device (represented by a file
which remains a on a NFS share).

Version-Release number of selected component (if applicable): 2.6.9-42.0.3.ELsmp

How reproducible: always, the bug doesn't trigger if you just read files

Steps to Reproduce:
1. Use the attached script to create a large enough FS image (on our production
server it's a 200GB file)
2. Use any other script or application which is able to create and write at
least ten files _concurrently_ in different directories (we have four level nesting)
3. Under such circumstances our server becomes entirely unresponsive, it either
hangs instantly, or it runs for around hour or two without allowing writing any
files to any  HDDs - so no SSH logins, crond tasks cannot start ... then it
hangs. If you are logged on at this time - you cannot even run top or ps - they
both hang at startup.
  
Actual results: hang


Expected results: work


Additional info:

1) I suppose this bug is not hardware related. This server (two Prescott based
Xeon CPUs) is located in a server room where temperature doesn't ever exceeds 20
degrees Celsius.

2) Usually when this server hangs a load average value is around 70-200.

Comment 1 Artem S. Tashkinov 2007-03-14 17:27:59 UTC
Created attachment 150068 [details]
A script in use

Comment 2 Artem S. Tashkinov 2007-10-20 13:45:41 UTC
You tried to change the Status field from NEW to CLOSED, but only the owner or
submitter of the bug, or a autorized user, may change that field. 

Comment 3 Chuck Ebbert 2007-10-21 15:45:20 UTC
(In reply to comment #2)
> You tried to change the Status field from NEW to CLOSED, but only the owner or
> submitter of the bug, or a autorized user, may change that field. 

Why do you want to close the bug?


Comment 4 Artem S. Tashkinov 2007-10-21 18:21:07 UTC
Due to frequent kernel crashes, we retracted from using this solution. Besides
in seven (!) months you are the first person to notice this bug. My employer
couldn't wait for seven months - since that we implemented a different solution.

Comment 5 Chuck Ebbert 2007-10-22 16:14:56 UTC
Bug was not assigned properly. kernel-maint is for the Fedora kernel.


Note You need to log in before you can comment on or make changes to this bug.