Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232263 - out of memory and backlog exceeded
Summary: out of memory and backlog exceeded
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 16:31 UTC by cje
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-12 22:08:42 UTC


Attachments (Terms of Use)

Description cje 2007-03-14 16:31:58 UTC
Description of problem:
attempting to apply the latest set of updates my system is hung with all swap
memory consumed and i think it's selinux/setroubleshoot that's causing the
trouble.  (it's hard to be sure because i can't get a login to see what's going on.)

before it got stuck i noticed the setroubleshoot icon had appeared in the panel.  

also i'm pretty sure i've seen this before and caught it before it killed the
system.  on that occasion i think the problem process was called sealert and it
was rapidly consuming memory and writing continual messages to the console.

with the current situation i can, if i'm very patient, get to the other ttys and
see messages about all swap being used up and messages about an avc backlog
being exceeded.

Comment 1 cje 2007-03-14 19:02:39 UTC
FYI, powered off the machine, booted back up and allowed pup to apply the
remaining updates.  so far all seems to be okay again.  i was expecting serious
damage to the filesystem and the rpm database.  perhaps times have changed.

so, not sure if this counts as fixed.  up to you.

Comment 2 John Dennis 2007-06-12 22:08:42 UTC
Boy, this is a tough one to diagnose. One of two things could have happened. If
you had labeling problems during the update you might have generated a slew of
AVC's that setroubleshoot was trying to respond to. Or, setroublehoot could have
hit a bug that caused it to behave badly. Since this does not seem to be
reproducible I'm going to close it. But should it occur again the contents of
/var/log/audit/audit.log and /var/log/setroubleshoot/setroubleshootd.log would
be very helpful in diagnosing.

Comment 3 cje 2007-06-13 10:17:27 UTC
cool.  thanks for thinking about it.  i'll keep an eye out for it happening again.

:-)


Note You need to log in before you can comment on or make changes to this bug.