Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232201 - NetworkManager with ipw2200 not working
Summary: NetworkManager with ipw2200 not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 09:20 UTC by gareth foster
Modified: 2018-04-11 14:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-09 21:04:20 UTC


Attachments (Terms of Use)
lspci command output (deleted)
2007-03-15 21:17 UTC, gareth foster
no flags Details
log output (deleted)
2007-03-15 21:19 UTC, gareth foster
no flags Details

Description gareth foster 2007-03-14 09:20:39 UTC
Description of problem:
Until recently, NetworkManager had worked fine on my laptop, however now it
can't detect any wireless networks, or connect to the wired network.

The only way I can connect now is by using the old command ...

/sbin/service network start

I have to disable NetworkManager completely. I asked about on IRC and found one
other bloke with the same problem, but no solution. Google wasn't helping much
either.

Anyway, this is pretty serious for people with laptops using this setup, so I
thought I'd better file a bug.

Version-Release number of selected component (if applicable):
Latest all, yum updated after connecting to network manually last night (13th),
same problem.

How reproducible:
I've booted the machine several times over the last few weeks. It never works
any more.

Comment 1 Matěj Cepl 2007-03-14 14:05:59 UTC
Hi, Gareth,

I think we need more detailed information about the nature of your problem. What
exactly does it mean, that "it doesn't work"? Are there any error messages, etc.
displayed?

Could you run (as a root) this command

tail -n 500 /var/log/messages >/tmp/bug232201-testcase.txt

and attach the file /tmp/bug232201-testcase.txt as an attachment to this bug
report, please?

If you run (again as root), this command what is the output?

iwlist eth1 scan

(of course, if your wi-fi card is something else than eth1, than change the
command accordingly)

What is the driver of your wi-fi card? Is it loaded (lsmod | grep
<name-of-driver-module>)?

Thanks a lot for your cooperation.

Comment 2 gareth foster 2007-03-14 15:30:38 UTC
> I think we need more detailed information about the nature of your problem. What
> exactly does it mean, that "it doesn't work"? Are there any error messages, etc.
> displayed?
>

No GUI based error messages, no. Just there are no wireless networks listed as
available, and the wired network tries to connect for rather a long time before
failing.

I'll give those commands a spin tonight if I get time.

Comment 3 Matěj Cepl 2007-03-14 22:42:15 UTC
Sorry, for nitpicking, but this still in NEEDINFO.

Comment 4 gareth foster 2007-03-15 21:16:16 UTC
[root@d3ath earthwormgaz]# /sbin/iwlist eth1 scan
eth1      No scan results

... Hmm, not good. The card appears to be (from lspci) ...

01:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)

I've made some attachments as you asked to go with the report.

Interestingly, the wired network connects if I plug in the ethernet cable before
booting the laptop. However, I'm still not seeing any wireless networks.

I do have this RPM installed in case you were wondering ...

ipw2200-firmware-3.0-1.lvn6

Comment 5 gareth foster 2007-03-15 21:17:51 UTC
Created attachment 150173 [details]
lspci command output

Comment 6 gareth foster 2007-03-15 21:19:52 UTC
Created attachment 150174 [details]
log output


Note You need to log in before you can comment on or make changes to this bug.