Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232183 - yumdownloader Crashes When Using --resolve
Summary: yumdownloader Crashes When Using --resolve
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 04:57 UTC by Jonathan Steffan
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-18 08:39:49 UTC


Attachments (Terms of Use)
fixed packages.py (deleted)
2007-04-13 09:20 UTC, Tim Lauridsen
no flags Details

Description Jonathan Steffan 2007-03-14 04:57:45 UTC
Description of problem:
When using yumdownloader, --resolve option produces traceback.

Version-Release number of selected component (if applicable):
yum-utils-1.0.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.yumdownloader --resolve yum-utils
2.yumdownloader --source --enablerepo=extras-source yum-utils
  
Actual results:
Bin:
yum-utils-1.0.3-1.fc6.noa 100% |=========================| 6.4 kB    00:00     
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 159, in main
    if not pkg in toDownload:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: TransactionMember instance has no attribute 'ver'

Source:
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
yum-utils-1.0.3-1.fc6.src 100% |=========================| 4.0 kB    00:00     
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 156, in main
    my.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 191, in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 150, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 454, in getHeader
    cache=cache,
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
yum.Errors.RepoError: failure: yum-utils-1.0.3-1.fc6.src.rpm from extras-source:
[Errno 256] No more mirrors to try.

Expected results:
It works.

Comment 1 warren 2007-03-14 05:15:28 UTC
yes indeed, same results here.

-opsec #fedora

Comment 2 Michael DeHaan 2007-04-10 21:54:39 UTC
Confirmed, me too...

/usr/bin/yumdownloader
--config=/var/www/cobbler/repo_mirror/.origin/fc6x86_64extras.repo
--destdir=/var/www/cobbler/repo_mirror --resolve koan cobbler

Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 159, in main
    if not pkg in toDownload:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: TransactionMember instance has no attribute 'ver'

The config file has the following contents:

[fc6x86_64extras]
name=fc6x86_64extras
baseurl=http://mirrors.kernel.org/fedora/extras/6/x86_64/
enabled=1
gpgcheck=0

    


Comment 3 Tim Lauridsen 2007-04-11 07:35:08 UTC
>> AttributeError: TransactionMember instance has no attribute 'ver'

This one should be solved in yum-3.0.5 currently in the updates repo, please update.

Comment 4 Michael DeHaan 2007-04-11 15:20:24 UTC
Same command, different error ...

[root@mdehaan cobbler]# /usr/bin/yumdownloader
--config=/var/www/cobbler/repo_mirror/.origin/fc6x86_64extras.repo --resolve
--destdir=/var/www/cobbler/repo_mirror/fc6x86_64extras cobbler koan
python-cheetah yum-utils
livna                     100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
core                      100% |=========================| 1.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 159, in main
    if not pkg in toDownload:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if other == None: 
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 403, in
__cmp__
    if self.name > other.name:
AttributeError: 'NoneType' object has no attribute 'name'


Comment 5 Tim Lauridsen 2007-04-13 09:20:53 UTC
Created attachment 152526 [details]
fixed packages.py

Comment 6 Tim Lauridsen 2007-04-13 09:22:57 UTC
Michael:
Please try to replace
/usr/lib/python2.4/site-packages/yum/packages.py
with the attached one, to see if it fixes the problem.

Comment 7 Tim Lauridsen 2007-04-13 09:47:55 UTC
Ok, i have reproduced the error and is fixed with the attached packages.py.
I have sumbitted it to upstream CVS for yum-3.1.x and yum-3.0.x.

it should be available in yum-3.0.7 and yum-3.1.7

Comment 8 Michael DeHaan 2007-04-13 15:19:50 UTC
Works for me, thanks.

Ship it!




Note You need to log in before you can comment on or make changes to this bug.