Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232147 - Wrong DMA mode probed / Can't set mode > udma(33)
Summary: Wrong DMA mode probed / Can't set mode > udma(33)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 23:28 UTC by goahead
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 23:26:40 UTC


Attachments (Terms of Use)
output of hdparm -iI on FC6 and on Kanotix, dmesg (deleted)
2007-03-13 23:28 UTC, goahead
no flags Details

Description goahead 2007-03-13 23:28:57 UTC
Description of problem: udma(133) ide disk gets wrongly detected as udma(33) 
and it is not possible to set it to anything above udma(33) with hdparm.


Version-Release number of selected component (if applicable): 2.6.19-
1.2911.6.5.fc6


How reproducible: always


Steps to Reproduce:
1. Boot the system
2. 
3.
  
Actual results: Have to use a udma6 disk in udma2 mode, getting 27MB/s instead 
of 56MB/s


Expected results: Correct detection of harddisk 


Additional info: The IDE driver / Southbridge used are SIS5513 / SIS962. Same 
system is detected correctly and works fine in udma6 mode with 2.6.12-
1.1378_FC3 and with Knoppix or Kanotix (2005-02) Live CDs. And yes, I'm using a 
80pole cable.

Comment 1 goahead 2007-03-13 23:28:57 UTC
Created attachment 150003 [details]
output of hdparm -iI on FC6 and on Kanotix, dmesg

Comment 2 goahead 2007-03-14 19:34:04 UTC
The same system with kernel 2.6.19-1.2895.fc6 does not show this issue. The 
harddisk is recognized correctly and operates in udma6 mode.

Comment 3 Chuck Ebbert 2007-03-14 20:58:32 UTC
Please test 2.6.20-1.2925.fc6

Comment 4 goahead 2007-03-15 19:09:33 UTC
Just tested 2.6.20-1.2925.fc6. It shows the same problem. Only udma2 or less 
possible.

Comment 5 Chuck Ebbert 2007-03-26 14:37:01 UTC
Test kernels (1.2937) for this issue are at:

http://people.redhat.com/cebbert

Please test and report back.


Comment 6 goahead 2007-03-27 22:20:53 UTC
Tested kernel 1.2937. This time the harddisk is detected correctly as udma6. The
speed hdparm reports corresponds to this disks normal udma6 speed. It is also
possible to set the speed to any value up to udma6. It seems the issue is
resolved in this kernel. Thanks.


Note You need to log in before you can comment on or make changes to this bug.