Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232097 - rhn-applet does not change from red ! to blue checkmark when system is fully updated
Summary: rhn-applet does not change from red ! to blue checkmark when system is fully ...
Keywords:
Status: CLOSED DUPLICATE of bug 232679
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet
Version: 4.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Shannon Hughes
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 21:07 UTC by Beth Nackashi
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 16:24:25 UTC


Attachments (Terms of Use)
illustration of the same happening on RHEL4/i386 xen guest (deleted)
2007-06-14 15:09 UTC, Matěj Cepl
no flags Details

Description Beth Nackashi 2007-03-13 21:07:49 UTC
Description of problem:


Version-Release number of selected component (if applicable):
rhn-applet-2.1.25-22

How reproducible:
x86_64

Steps to Reproduce:
1.  Load the latest rhn-applet onto an x86_64 box.
2.  Update the box fully.
3.  
  
Actual results:
rhn-applet will never change to blue checkmark, even if you restart the applet,
change the rhnsd interval and restart that, etc.

Expected results:
rhn-applet changes to blue checkmark

Additional info:

Comment 1 Beth Nackashi 2007-03-13 21:09:41 UTC
Ooop, sorry.  Forgot to fill in the Description of problem.

The rhn-applet never changes from the red exclamation point to the blue
checkmark when an x86_64 box is fully updated.  It works on i386.

Comment 3 Shannon Hughes 2007-03-20 16:24:25 UTC
there is a known issue with the server side applet xmlrpc handlers only able to
send back server arch information instead of sending back multiple arches in the
case of a x86_64 channel. this is the same issue with 232679. marking this one
as a duplicate and encourage qa to use both bugs as separate test cases when
verifying. 

*** This bug has been marked as a duplicate of 232679 ***

Comment 4 Matěj Cepl 2007-06-14 15:09:57 UTC
Created attachment 157010 [details]
illustration of the same happening on RHEL4/i386 xen guest

The same problem with xen RHEL4/i386 full-virt xen guest on F7/x86_64 host.


Note You need to log in before you can comment on or make changes to this bug.