Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232091 - DVD+ media will results in vary verbose output.logs
Summary: DVD+ media will results in vary verbose output.logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: YangKun
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 20:59 UTC by Rob Landry
Modified: 2008-07-16 21:58 UTC (History)
0 users

Fixed In Version: RHBA-2007-0736
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-02 16:29:59 UTC


Attachments (Terms of Use)
Patch for -21 to add quiet mkisofs option to the growisofs that dvd+ media uses; also picks up the -J to make cleaner coasters for CD's; from -21 it seems the DVD already had -J (deleted)
2007-03-13 20:59 UTC, Rob Landry
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0736 normal SHIPPED_LIVE hts bug fix available 2007-10-24 15:32:42 UTC

Description Rob Landry 2007-03-13 20:59:12 UTC
Description of problem:

$summary; in addition to spewing all over the screen the hardware catalog won't
like some portion of these results since they can be 10+ MB in size; as well
they're not easy for human parsing either.

Version-Release number of selected component (if applicable):

hts-5.0-21; though it appears almost the same in -31; I'll attach a patch as
well, but it appears -21 already include the Juliet extention that seemed to be
missing from -31; not certain what that's about.

How reproducible:

Everytime with DVD+R or DVD+RW media.

Comment 1 Rob Landry 2007-03-13 20:59:12 UTC
Created attachment 149984 [details]
Patch for -21 to add quiet mkisofs option to the growisofs that dvd+ media uses; also picks up the -J to make cleaner coasters for CD's; from -21 it seems the DVD already had -J

Comment 2 YangKun 2007-03-14 05:20:51 UTC
Rob, we can NOT use Juliet extention(-J) because it has:
    o File Name Length limitations
    o Directory Tree Depth limitations
the limitation should be 128(expressed as a number of bytes). For some
"long-name" files(e.g. some files under /usr/share/doc/ ), the file names will
be truncated , and this will lead to the "duplicate file" error . So I removed
"-J" since R21. (there is a bug addressing this "duplicate file" error, but I
can not recall the bug ID)

I've added the "-quiet" to growisofs in cdrom test, and tested it on my machine,
this fix is in R32.

Comment 5 Red Hat Bugzilla 2007-08-02 16:29:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0736.html



Note You need to log in before you can comment on or make changes to this bug.