Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 232090 - TypeError on selecting Fedora Extras with dynamic IP
Summary: TypeError on selecting Fedora Extras with dynamic IP
Keywords:
Status: CLOSED DUPLICATE of bug 213356
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 20:55 UTC by Pavel Roskin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-14 18:25:51 UTC


Attachments (Terms of Use)

Description Pavel Roskin 2007-03-13 20:55:45 UTC
Description of problem:
Selecting Fedora Extras in the current FC6 respin fails (even with dynamic IP)

Version-Release number of selected component (if applicable):
11.1.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Rebuild the installation DVD with all updates using pungi.
2. Try installing FC6 from that DVD.
3. Select dhcp in the network configuration.
4. Select Fedora Extras in the package selection dialog
5. Select the wired interface and dhcp and click OK
  
Actual results:
An "Exception occurred" dialog appears.  It reads:
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 215 in _ok
    _("Error configuring network device")
TypeError: parent should be a GtkWindow or None

Local variables in innermost frame:
val: eth0
netdev: DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0E:7B:84:5C:8D
ONBOOT=yes

self: <netconfig_dialog.NetworkConfigurator instance at 0xb7bf550c>
args: (<gtk.Button object (GtkButton) at 0xb19f284>,)
w: <gui.WaitWindow instance at 0xab721ac>
combo: <gtk.ComboBox object (GtkComboBox) at 0xb19f2ac>
active: <GtkTreeIter at 0xa9a9258>
ns:None

Expected results:
The interface is brought up and Fedora Extras becomes available, or at least I
get an error message from which I can recover.

Additional info:
This is not bug #212018 (AnacondaExtrasConfig).  This bug happens with the
updated current Anaconda and doesn't require static address to be selected.

There are two network interfaces on the system: Intel wired (e1000) and Intel
wireless (ipw-3945).  The wireless interface is not detected.  The wired
interface is detected and is registered as eth0 with the e1000 driver.  I can
see it by doing:

ls -ald /sys/class/net/eth0/device/driver

on the text console after the failure.  I select eth0.  I know that it sometimes
fails to detect carrier, but it's not an excuse for a failure with traceback. 
Moreover, I brought eth0 up manually and I see the carrier (cat
/sys/class/net/eth0/carrier gives 1).

I believe the message is caused by incorrect use of the first argument to
gtk.MessageDialog, which should be a window (e.g. self.parent as in
partition_gui.py and raid_dialog_gui.py) or None.

netconfig_dialog.py passes a string instead in two places, on lines 135 and 213.

I also tested the same disk on another system with no problems with carrier, and
I'm still getting the same problem.  Apparently, there is also a failure to
obtain an IP address in addition to the problem displaying the error message.

Comment 1 Chris Lumens 2007-03-14 18:25:51 UTC
Respins don't include updated anaconda builds.  While your problem isn't
AnacondaExtrasConfig, it's another relatively often reported FC6 bug that's
fixed in anaconda-11.2.0.1.

*** This bug has been marked as a duplicate of 213356 ***


Note You need to log in before you can comment on or make changes to this bug.