Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231979 - clvmd does not recover locks when restarting
Summary: clvmd does not recover locks when restarting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Cluster QE
URL:
Whiteboard:
: 231995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 13:24 UTC by Christine Caulfield
Modified: 2013-03-01 04:05 UTC (History)
8 users (show)

Fixed In Version: RHBA-2007-0287
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-08 00:16:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0287 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2007-04-28 19:01:34 UTC

Description Christine Caulfield 2007-03-13 13:24:08 UTC
Description of problem:
When the daemon restarts, clvmd is supposed to re-acquire locks related to LVs
that are active on that node. This is no longer happening as the 'lvs' command
sematics changed some time ago.

Version-Release number of selected component (if applicable):
All current versions of LVM

How reproducible:
every time

Steps to Reproduce (on RHEL4):
1. activate some cluster LVs
2. # echo "clvmd" >/proc/cluster/dlm_locks
3. # cat /proc/cluster/dlm_locks
4. # killall clvmd
5. # clvmd
6. # cat /proc/cluster/dlm_locks

Actual results:
step #6 shows no locks

Expected results:
The same locks as shown in step #3

Additional info:

This is down to the way that the 'lvs' command has changed. 

When clvmd starts up it issues an command: lvs --nolocking to get a list of
logical volumes. Only this command now does not show clustered LVs - merely an
error stating that it won't!

We need either --nolocking to show all LVs, or some other switch that will
display clustered LVs without a locking attempt being made.
--ignorelockingfailure is not an option because it attempts to call into
clvmd...which is busy trying to start up.

Comment 1 Jonathan Earl Brassow 2007-03-13 14:54:21 UTC
*** Bug 231995 has been marked as a duplicate of this bug. ***

Comment 2 Christine Caulfield 2007-03-13 15:38:36 UTC
no_locking should be a clustered locking mode.

Checking in lib/locking/no_locking.c;
/cvs/lvm2/LVM2/lib/locking/no_locking.c,v  <--  no_locking.c
new revision: 1.11; previous revision: 1.10
done

Comment 11 Red Hat Bugzilla 2007-05-08 00:16:41 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0287.html


Note You need to log in before you can comment on or make changes to this bug.