Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231970 - removing secondary battery confuses estimates
Summary: removing secondary battery confuses estimates
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 12:03 UTC by cje
Modified: 2013-03-06 03:49 UTC (History)
2 users (show)

Fixed In Version: 0.5.9-0.git20070326
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-27 18:39:43 UTC


Attachments (Terms of Use)

Description cje 2007-03-13 12:03:21 UTC
Description of problem:
g-p-m knows i've got two batteries on my laptop - left-click on the panel icon
shows the details of both.  but it's not dealing with the removal of the
secondary one.
removing the secondary battery makes g-p-m just think the battery has just
instantly drained 70% of its power.  left-click on the panel icon still lists
the secondary as present.
rebooting refreshes the list of batteries.
adding the secondary battery (after booting without it) causes similar confusion
- the second battery isn't in the list when i left-click the panel icon.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. left-click panel icon
2. add or remove secondary battery
3. left-click panel icon
  
Actual results:
battery list not updated

Expected results:
battery list updated

Additional info:
this is on a toshiba portege P2000 (several years old)

Comment 1 cje 2007-03-13 12:11:52 UTC
(it's g-p-m 2.17.92)

Comment 2 cje 2007-03-13 14:02:35 UTC
lshal -m doesn't produce output when i plug in the secondary battery after
booting with only the primary installed.  does that mean this is a HAL problem?

Comment 3 cje 2007-03-13 15:03:21 UTC
with the secondary plugged in after booting without it:

lshal -l -u acpi_BAT2
says it's not present but

cat/proc/acpi/battery/BAT2/state
says it is.

since removing the secondary after booting with both causes g-p-m to say there's
29% remaining, doesn't that imply that g-p-m is getting some information from
HAL and some from /proc/acpi?  i would have thought it should be all HAL?

Comment 4 Richard Hughes 2007-03-13 15:12:06 UTC
All from HAL. This is probably the same as your other bug where we are not
getting an ACPI event when the battery is removed. If you do "lshal -m" and then
remove the battery you should get an event right away, if not, a HAL bug.

Comment 5 cje 2007-03-13 16:09:02 UTC
right, i don't get the event at all.  so that's a HAL bug.

ah, got it.  it's changing the percentage because removing external battery
(after booting with both) causes acpi_BAT2:battery.charge_level.percentage to be
removed in HAL.

as you say, all from HAL.  i've changed the component.  thanks again.  :-)

Comment 6 cje 2007-03-27 18:39:43 UTC
all fixed in hal-0.5.9-0.git20070326.fc7

:-)    thank you very much.


Note You need to log in before you can comment on or make changes to this bug.