Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 231964 - Satellite Installation documentation bug - database block size
Summary: Satellite Installation documentation bug - database block size
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Ha
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-13 09:52 UTC by Nick Strugnell
Modified: 2014-08-04 22:17 UTC (History)
2 users (show)

Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-03 00:35:55 UTC


Attachments (Terms of Use)

Description Nick Strugnell 2007-03-13 09:52:19 UTC
Description of problem:
The section in the installation guide for satellite regarding the configuration 
of an external database makes no mention of what database block size to use 
therefore we have used the defaults in all installations. However, the default 
on Oracle 9.2.0.1.0 for Windows 2000 is 4KB rather than the more usual 8KB. 
This turns out to be too small to hold the index keys for the 
rhn_pkg_cl_pid_n_txt_time_uq index created on the rhnPackageChangelog table. 
Thus, schema creation fails. Unfortunately this failure happens silently, and 
the problem is not apparent until satellite activation fails at a later stage 
of the install.pl script.

Version-Release number of selected component (if applicable):
4.1.5 however I suspect that this affects all versions of satellite.

How reproducible:
Always

Steps to Reproduce:
1. Configure external database with 4KB block size (the default on 9iR2 on 
Windows 2000)
2. Install satellite with external database
3.
  
Actual results:
Satellite activation fails. No further error messages are given. Further 
investigation shows the following in populate_db.log:- 
 
SQL> create unique index rhn_pkg_cl_pid_n_txt_time_uq 
        on rhnPackageChangelog(package_id, name, text, time) 
        nologging tablespace RHNSS_DATA 
storage ( freelists 16 ) 
        initrans 32; 
 
 
on rhnPackageChangelog(package_id, name, text, time) 
           * 
ERROR at line 2: 
ORA-01450: maximum key length (3118) exceeded 
 


Expected results:
Satellite installation should proceed normally.

Additional info:

Two things we need to do here:-

* Fix installer.pl so that it detects failure of the schema to create properly 
and does not carry on with the satellite installation.

* Fix documentation so that it states clearly that an 8KB minimum db_block_size 
is required to install satellite with an external database.

Comment 2 Brandon Perkins 2007-08-04 03:25:19 UTC
Reassign bugs to jha@redhat.com.

Comment 3 Michael Hideo 2007-11-05 23:50:01 UTC
Moving Status to 'Assigned'

Comment 4 John Ha 2007-12-20 21:15:05 UTC
This is fixed in the latest build of Satellite 5.1.0 Installation Guide. Here is
the content with the 8kb block size database requirement stated:

http://lacrosse.corp.redhat.com/~jha/rhn_510/installation-guide/s1-requirements-database.html

Comment 5 Corey Welton 2008-02-13 18:09:41 UTC
QA Verified, text exists in db requirements on iso.


Comment 6 Brandon Perkins 2008-04-03 00:35:55 UTC
5.1 Sat GA so Docs bugs Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.